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PART 1 

Ecommerce definition and types of ecommerce 

E-commerce is the process of buying and selling of various products and services by 

businesses through the Internet. It deals various kind of business concern, from retail site 

of the consumer, which includes auction. The main focus is to concentrate on business 

substitutes involving goods and services between various corporations. 

E-commerce is the purpose of Internet and the web to Conduct business but when we 

concentrate on commercial deals among organizations and individuals demanding 

selective information systems under the guarantee of the firm it accepts the form of e-

business. Nowadays, the word ‘e’ is hitting momentum. 

Ecommerce (e-commerce) or electronic commerce, a subset of ebusiness, is the 

purchasing, selling, and exchanging of goods and services over computer networks 

(such as the Internet) through which transactions or terms of sale are performed 

electronically. Contrary to popular belief, ecommerce is not just on the Web. In fact, 

ecommerce was alive and well in business to business transactions before the Web 

back in the 70s via EDI (Electronic Data Interchange) through VANs (Value-Added 

Networks). 

TYPES OF e COMMERCE: 

 Ecommerce can be broken into four main categories: B2B, B2C, C2B, and C2C.  

• B2B(Business-to-Business) 

Companies doing business with each other such as manufacturers selling to 

distributors and wholesalers selling to retailers. Pricing is based on quantity of 

order and is often negotiable. 

• B2C(Business-to-Consumer) 

Businesses selling to the general public typically through catalogs utilizing 

shopping cart software. By dollar volume, B2B takes the prize, however B2C 

is really what the average Joe has in mind with regards to ecommerce as a 

whole. 

 

Having a hard time finding a book? Need to purchase a custom, high-end 

computer system? How about a first class, all-inclusive trip to a tropical 

island? With the advent ecommerce, all three things can be purchased literally 

in minutes without human interaction. Oh how far we've come! 

• C2B(Consumer-to-Business) 

A consumer posts his project with a set budget online and within hours 

companies review the consumer's requirements and bid on the project. The 

consumer reviews the bids and selects the company that will complete the 

project. Elance empowers consumers around the world by providing the 

meeting ground and platform for such transactions. 

• C2C(Consumer-to-Consumer) 

There are many sites offering free classifieds, auctions, and forums where 

individuals can buy and sell thanks to online payment systems like PayPal 

where people can send and receive money online with ease. eBay's auction 

service is a great example of where person-to-person transactions take place 

everyday since 1995.  

Companies using internal networks to offer their employees products and services online--not 
necessarily online on the Web--are engaging in B2E (Business-to-Employee)ecommerce. 

 
G2G (Government-to-Government), G2E (Government-to-Employee), G2B (Government-to-
Business), B2G (Business-to-Government), G2C (Government-to-Citizen), C2G (Citizen-to-
Government) are other forms of ecommerce that involve transactions with the government--
from procurement to filing taxes to business registrations to renewing licenses. There are 
other categories of ecommerce out there, but they tend to be superfluous.  
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The difference between e-business and e-

commerce 
 E -business and e-commerce are terms that are sometimes used 

interchangeably, and sometimes they're used to differentiate one vendor's 

product from another. But the terms are different, and that difference matters to 

today's companies.  

In both cases, the e stands for "electronic networks" and describes the 

application of electronic network technology - including Internet and electronic 

data interchange (EDI) - to improve and change business processes.  

E-commerce covers outward-facing processes that touch customers, suppliers 

and external partners, including sales, marketing, order taking, delivery, 

customer service, purchasing of raw materials and supplies for production and 

procurement of indirect operating-expense items, such as office supplies. It 

involves new business models and the potential to gain new revenue or lose 

some existing revenue to new competitors.  

It's ambitious but relatively easy to implement because it involves only three 

types of integration: vertical integration of front-end Web site applications to 

existing transaction systems; cross-business integration of a company with Web 

sites of customers, suppliers or intermediaries such as Web-based marketplaces; 

and integration of technology with modestly redesigned processes for order 

handling, purchasing or customer service.  

E-business includes e-commerce but also covers internal processes such as 

production, inventory management, product development, risk management, 

finance, knowledge management and human resources. E-business strategy is 

more complex, more focused on internal processes, and aimed at cost savings 

and improvements in efficiency, productivity and cost savings.  

An e-business strategy is also more difficult to execute, with four directions of 

integration: vertically, between Web front- and back-end systems; laterally, 

between a company and its customers, business partners, suppliers or 

intermediaries; horizontally, among e-commerce, enterprise resource planning 

(ERP), customer relationship management (CRM), knowledge management and 

supply-chain management systems; and downward through the enterprise, for 

integration of new technologies with radically redesigned business processes. But 

e-business has a higher payoff in the form of more efficient processes, lower 

costs and potentially greater profits.  

E-commerce and e-business both address these processes, as well as a 

technology infrastructure of databases, application servers, security tools, 

systems management and legacy systems. And both involve the creation of new 

value chains between a company and its customers and suppliers, as well as 

within the company itself.  

All companies should have an e-commerce strategy. (Governments should have 

an e-public service strategy.) Electronic networks in general and the Internet in 

particular are too important for firms to ignore if they want to interact with 

customers, suppliers or distribution partners.  

But some companies need to move beyond e-commerce and form e-business 

strategies - especially large companies that already have links to EDI networks or 

have completed major ERP implementations. These companies have already 

reaped some of the biggest benefits from e-commerce strategies. They're also 

likely to experience organizational pain as conflicts develop among their ERP, 

EDI, supply-chain management and e-commerce strategies. And last, they have 

enough experience and knowledge in electronic-network technologies - and in 

process redesign and integration - that they have a chance of being successful in 

an e-business strategy.  

Still, the coordination and organizational obstacles to developing an e-business 

strategy are formidable. It involves major and potentially disruptive 

organizational change. The risks of failure and the consequences from limited 

success are higher in an e-business strategy than in an e-commerce strategy. 

Being a leader in e-business can contribute to long-term success, but the stresses 

and strains of business transformation can cause near-term damage.  

A wise company may decide to consolidate its gains and complete the work 

involved in its existing and largely separate e-commerce, ERP, CRM or supply-

chain initiatives before making the big leap to becoming an e-business 
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What are the features of e-commerce? 
 

E-commerce is the use of internet and the web to make business 

transactions. Millions of people make purchases on the web, so what makes e-

commerce so special?  

There are 8 unique features of e-commerce that make it so successful.  

The first thing that makes e-commerce so great is Ubiquity; it is available 

everywhere at anytime. Online the stores never close. Online shopping has hurt 

traditional businesses in some ways and helped it in other ways. A positive thing is 

clicks-and-bricks; you can order online and pick it up at the store. E-commerce has 

forced business to get online or loss business. One of the negatives is that e-

commerce takes away business from traditional businesses. It hurts small "mom and 

pop" shops as well as big business. Office supply companies like Staples and 

OfficeMax send out coupons offering $10 off $50 if you buy in-store instead of online 

so they can reduce in store stock and increase sales. Many companies have a sales 

quota to make for each store and if they don't they will have to close that store.  

Global Reach is a great feature of e-commerce. It takes the marketplace to 

marketspace. You can go "shopping" all around the world in one place. This has 

given businesses a chance to reach other markets and to billions of potential 

customers. I think that traditional businesses traditionally advertised on the radio, 

billboards and then television, but when the web was created it opened another 

world for business and advertising. Traditional businesses now advertise online, it is 

much more affordable and reaches more consumers than television or radio. Sites 

like Google offer advertising that you are charged per clicks. For every person who 

visits your site, you pay five cents opposed to paying $500 to advertise on the radio 

and no one or only a few people go to your store or website.  

Universal Standards are standards shared by the world. This is a revolutionary thing 

for not just e-commerce but the world. It gives us all the ability to connect at the 

same "level" and it provides network externalities that will benefit everyone. 

Universal standards ties in with global reach; it is one giant marketplace. There are 

lower entry costs and minimal search costs compared to traditional commerce. I 

think that universal standard benefits have forced traditional businesses' into 

improving on their customer service. Traditional businesses attempt to lower search 

costs by offering to search for you. Best Buy will let you go into the store and 

compare all appliance store prices so you don't have to "shop around". Many stores 

will also call all their other stores or get it from their site shipped to the store so you 

don't have to go anywhere. If Staples does have something you need in stock will 

actually order it for you and personally deliver it to your door.  

Richness is the complexity and content of a message. I usually think about 

marketing and sales pitches I think about richness. You go to the department store 

to buy perfume or make-up and you get personal attention. Everyone loves to feel 

special and important. The web and e-commerce has made it possible to deliver the 

same kind of "feeling" or message without the face to face interaction. I think this 

has made traditional business make greater improvement in their customer service 

so they can make a traditional shopping experience richer than ever before. My store 

like Areopostale, DEB and Wal-Mart hire greeters or shopping helpers to enhance 

your shopping experience.  

Interactivity allows online merchants to engage consumers in face-to-face like 

interactions without an actual face to face experience. E-commerce interactivity is 

much better because businesses can interact on a much larger scale. E-commerce 

can collect information from consumers more easily and efficiently with forms and 

surveys. In an attempt to compete with online stores, many traditional businesses 

like JC Penny print surveys with all their receipts and offer a discount on your next 

shopping trip for filling it out.  

Information density offers consumers better quality information and more of it. My 

example goes along with interactivity. Many companies like Best Buy offer price 

comparison and price matching, because e-commerce prices are more transparent so 

traditional business try to compete with e-commerce by making traditional shopping 

easier for consumers.  

Personalization and Customization are tailoring messages and products to consumers 

based on their preferences. Websites like MSN let you customize your homepage to 

all the information you want and they also place advertising on your page based on 

your preferences. Customization is something really hard for traditional businesses to 

do because just like richness the more people it reaches the less customized it gets. 

I think the closest thing to customization traditional businesses have come up with 

are specialty stores. You see a lot more stores for specific groups, like big & tall 

stores, maternity and plus size stores created by businesses looking to reach other 
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markets that needs weren't really being met. Even traditional stores like Target, 

Kohl's and Wal-mart have expanded their specialty departments. E-commerce has 

opened the door to unlimited goods for shoppers, so unless the traditional 

businesses attempt to keep up with this demand, they will lose certain groups to 

completely online shopping. 

 

TYPES OF E-COMMERCE 
 

 

 

 

 

There are primarily five types of e-commerce models: 

Business to Consumer (B2C) 

 

B2C stands for Business to Consumer as the name suggests, it is the model taking 

businesses and consumers interaction. Online business sells to individuals. The basic 

concept of this model is to sell the product online to the consumers. 

B2c is the indirect trade between the company and consumers. It provides direct selling 

through online. For example: if you want to sell goods and services to customer so that 

anybody can purchase any products directly from supplier’s website. 

Directly interact with the customers is the main difference with other business model. As 

B2B it manages directly relationship with consumers, B2C supply chains normally deal 

with business that are related to the customer.  

Business to Business (B2B) 

 

B2B stands for Business to Business. It consists of largest form of Ecommerce. This 

model defines that Buyer and seller are two different entities. It is similar to manufacturer 

issuing goods to the retailer or wholesaler. Dell deals computers and other associated 

accessories online but it is does not make up all those products. So, in govern to deal 

those products, first step is to purchases them from unlike businesses i.e. the producers of 

those products. 

“It is one of the cost effective way to sell out product through out the world” 

Benefits: 



Sardar azeem PICT 7 

AZEEM_AAG2000@YAHOO.COM  03135879331 

• Encourage your businesses online 

• Products import and export 

• Determine buyers and suppliers 

• Position trade guides 

Consumer to Consumer (C2C) 

C2C stands for Consumer to Consumer. It 

helps the online dealing of goods or services 

among people. Though there is no major 

parties needed but the parties will not fulfill 

the transactions without the program which is 

supplied by the online market dealer such as 

eBay.  

Peer to Peer (P2P) 

 

It is a discipline that deal itself which assists people to 

instantly shares related computer files and computer 

sources without having to interact with central web 

server. If you are going to implement this model, both 

sides demand to install the expected software so that 

they could able to convey on the mutual platform. 

This kind of e-commerce has very low revenue 

propagation as from the starting it has been tended to 

the release of use due to which it sometimes caught 

involved in cyber laws. 

m-Commerce 

 

It deals with conducting the transactions with the help 

of mobile. The mobile device consumers can interact 

each other and can lead the business. Mobile 

Commerce involves the change of ownership or rights 

to utilize goods and related services. 

 
 

 

 

Element of a business model  

  

What is a business model, and why do freelancers and self employed people need one? 

A business model describes the reasoning behind how an organization or individual 

creates, delivers and captures value. Essentially, it is the framework through which an 

organisation makes money. 

If you don’t have one in place, your money-making strategy is likely to be cloudy, less 

efficient, and confusing for you. 

As a freelancer, you are in the business of creating and capturing value in this way, so it 

is crucial that you have a model in place when you set out to do business. 

Here are 9 key elements of business models for creatives that you would benefit 

from knowing. 
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1. Customer Segments 

This defines the different groups of people your creative work is aimed at. Make sure you 

know specifically who you are working and marketing for. 

2. Value Proposition 

This describes the value you are delivering to your customers. This is the response to the 

question: ‘What problems of our customers are we helping to solve?’ 

The value proposition of a graphic user interface designer, might be to improve the user 

experience of people using a site that would be of interest to site owners, for example. 

3. Channels 

Your business channels cover the methods you use in showing and delivering your 

potential customers the value in your product or service. 

This could include the website you use in selling your products and the social networking 

sites you use in sharing information about your business. 

4. Customer Relationship/s 

You should be thinking about how to engage with your customers, and how to carry out a 

long term relationship with them. If you are dealing with more than one customer 

segment, you might find a very different type of relationship style is required. 

For example, it might be crucial to dedicate considerable time in dealing with some 

clients face to face or on the phone. 

With a different area of business, such as in selling merchandise, for example, it might be 

sufficient to make the process more automated and less personal, but it all depends on the 

nature of the market segment you are dealing with. 

5. Revenue Streams 

This represents the money you generate from one or more market segments. 

You need to be crystal clear on exactly how you intend to create revenue from your 

business. For most creative freelancers, it would be a case of agreeing to carry out a 

service of some kind, and being paid on a ‘per job’ basis. 

As another example, an alternative revenue stream could be subscription payments 

brought in from the customers of a printed magazine. 

6. Key Resources 

This describes the most important assets required to make a business model work and is 

key in the functioning of all other aspects of the model. 

Such resources are all the elements required to contribute to your Value Proposition (2.), 

including your own personal skill, but also physical assets like software, hardware, 

printers, canvases, cameras and scanners. 

7. Key Activities 

These are activities that are crucial in making the business work. Like key resources, such 

activity is required to create and offer a strong Value Proposition, reach markets, 

maintain existing customer relationships, and earn revenue. 
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A key activity for a web designer might be in solving problems of web user experience 

and require face to face meetings with clients, whereas for a sports photographer, this 

would be in preparing for and documenting sports events, as well as delivering 

photographs electronically to customers. 

8. Key Partnerships 

These describe one’s network of suppliers and partners that exist to allow a business to 

function properly. 

In some cases, partnership for freelancing or other creatives are not a part of their 

business model, but others, such as in the case of a collaborative group of illustrators 

working together or in marketing the work of a combined illustration collective, can act 

as a powerful element of an effectively functioning business. 

9. Cost Structure 

This defines how you go about paying for the things you use within your business. Being 

clear on your cost structure is an important element of your business model because it 

will define where and when you add or subtract costs. 

You might create luxury furniture requiring high value materials. In which case, your 

business would be more value-driven, and depend on more expensive items. 

Fundamentals of Internet 

INTRODUCTION  

The latest buzzword in computer world is ‘Internet’. It has taken the entire world by 

surprise with its cutting edge technology to connect people and computers throughout the 

world. Using Internet, organizations all over the world can exchange data, people can 

communicate with each other in a faster and effective way, and researchers can gather 

information in their respective area of research. With help of video conferencing over 

Internet, it has become possible that people can even see each other while communicating 

and it is possible by video conferencing over Internet. Even one can do all his shopping 

sitting back at home. He does not bother to go to the crowded market place. Slowly 

shopkeepers are also opting for electronic commerce, which provides them greater reach 

and fastest way to do business over Internet. Don’t get surprised, if you come to know 

that the Paanwalla in your locality has started selling his paan over Internet. 

OBJECTIVES 

At the end of this lesson you would be able to:  

• define Internet  

• understand and explain various terminology used in Internet  

• use various services provided by Internet  

• search for information over Internet  

• enjoy Internet surfing  

• send E-mail and do FTP  

Internet- The History? 

In 1969, the U.S. Defence Department funded a project to develop a network, which can 

withstand the bombing. Basically the idea was to develop a very secure network which 

can work even after a nuclear attack. This project was known as ARPANET. The 

proposed network was not supposed to have a central control—which would be an 

obvious target. Ten years of research brought Local Area Ethernet Networks (LANs) and 
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workstations were developed to get connected to LAN. These workstations and LANs 

were then connected to the ARPANET. For next decade the ARPANET grew and its 

decentralized features helped its rapid expansion. Computers connected to ARPANET 

used a standard or rule to communicate with each other. This standard used by 

ARPANET is known as NCP (National Control Protocol). Protocol is a network term 

used to indicate the standard used by a network for communication. But the passing time 

and rapid change in information technology suppressed NCP and brought TCP/IP 

(Transmission Control Protocol/Internet Protocol) in to the world of networking. TCP 

"converts messages into streams of packets at the source, and they are reassembled back 

into messages at the destination. IP handles the dispatch of these packets. It handles the 

addressing, and makes sure that a packet reaches its destination through multiple nodes 

and even across multiple networks with multiple standards. This flexibility of TCP/IP to 

handle multiple networks with multiple protocols encourages other networks to get 

connected to ARPANET. Slowly the ARPANET became a massive network of networks 

and now it is known as ‘Internet’.  

Internet is termed by some people as the world of largest democracy with no government. 

It has no state of head to control it.  

Why do people want to get connected to Internet? May be because of freedom it 

provides. The Internet is a rare example of a large democracy with no state of head, no 

official censors, no bosses, no board of directors. Nobody controls the Internet and in 

principle, any computer can speak to any other computer, as long as it obeys the technical 

rules of the TCP/IP protocol. This freedom of Internet helped it to move out of its 

original base in military and research institutions, into elementary and high schools, 

colleges, public libraries, commercial sectors even into the shop of a vegetable vendor. 

Services of Internet - E-mail, FTP, Telnet, WWW 

But what does one do with the Internet? May be four things, basically: mail, discussion 

groups, long-distance computing, and file transfers. Internet mail is (e-mail or electronic 

mail), much faster as compared to normal postal mail. One can also send software and 

certain forms of compressed digital image as an attachment. News groups or discussion 

groups facilitate Internet user to join for various kinds of debate, discussion and new 

sharing. Long-distance computing was an original inspiration for development of 

ARPANET and does still provide a very useful service on Internet. Programmers can 

maintain accounts on distant, powerful computers, execute programs. File transfers 

service allows Internet users to access remote machines and retrieve programs, data or 

text.  

E-Mail (Electronic Mail) 

E-mail or Electronic mail is a paperless method of sending messages, notes or letters 

from one person to another or even many people at the same time via the Internet. E-mail 

is very fast compared to the normal post. E-mail messages usually take only few seconds 

to arrive at their destination. One can send messages anytime of the day or night and it 

will get delivered immediately. You need not to wait for the post office to open and you 

don’t have to get worried about holidays. It works 24 hours a day, seven days a week. 

What’s more, the copy of the message you have sent will be available whenever you want 

to look at it - even in the middle of the night. You have the privilege of sending 

something extra even such as a file, graphics, images etc. along with your e-mail. The 

biggest advantage to using e-mail is that it is cheap, especially when sending messages to 

other states or countries and at the same time it can be delivered to a number of people 

around the world. 

Although e-mail is faster and cheaper, it has many of the components of regular mail. It 

allows you to compose note, get the address of the recipient and send it. Once the mail is 

received and read, it can be forwarded, replied. One can even store it for later use, or 
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delete. In e-mail even the sender can request for delivery receipt and read receipt from the 

recipient. 

Features of E-mail:  

• One-to-one or one-to-many communications  

• Instant communications  

• Physical presence of recipient is not required  

• Most inexpensive mail service, 24-hours a day and seven days a week  

• Encourages informal communication  

Components of an E-mail Address  

As in the case of normal mail system, e-mail is also based upon the concept of a recipient 

address. The email address provides all of the information required to get a message to 

the recipient from anywhere in the world. Consider the e-mail ID 

john@hotmail.com 

In the example above, "john" is the local part, which is the name of a mailbox on the 

destination computer, where finally the mail will be delivered. Hotmail is the mailserver 

where the mailbox "john" exists, .com is the type of organisation on net, which is hosting 

the mail server.  

There are six main categories;  

com Commercial institutions or organization  

edu Educational institutions  

gov Government site  

mil Military site  

net Gateways and administrative hosts  

org Private organizations 

FTP (File Transfer Protocol) 

File Transfer Protocol, is an Internet utility software used to upload and download files. 

It gives access to directories or folders on remote computers and allows software, data 

and text files to be transferred between different kinds of computers. FTP works on the 

basis of same principle as that of Client/Server. FTP "Client" is a program running on the 

your computer that enables you to talk to, and get stuff from, remote computers. The FTP 

client takes FTP commands and sends them as requests for information from the remote 

computer or known as FTP servers. To access remote FTP server it is required but not 

necessary to have an account in the FTP server. When the FTP client gets connected, FTP 

server asks for the identification in-terms of User Login name and password of the FTP 

client. If one does not have an account in the remote FTP server, still he can connect to 

the server using anonymous login. 

Using anonymous login anyone can login in to a FTP server and can access public file 

archives, anywhere in the world, without having an account. One can easily Login to the 

FTP site with the username anonymous and e-mail address as password. 

The basic objectives of FTP are  

• to give flexibility and promote sharing of computer programs, files and data  
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• to transfer data reliably and more efficiently over network  

• to encourage implicit or indirect use of remote computers using Internet  

• to shield a user from variations in file storage systems among hosts.  

The basic steps in an FTP session are:  

• Start up your FTP client; by typing ftp on your system’s command line/’C>’ 

prompt (or, if you are in a Windows, double-click on the FTP icon).  

• Give the FTP client an address to connect to. This is the FTP server address to 

which the FTP client will get connected  

• Identify yourself to the FTP remote site by giving the Login Name  

• Give the remote site a password  

• Remote site will verify the Login Name/Password to allow the FTP client to 

access its files  

• Look directory for files in FTP server  

• Change Directories if required  

• Set the transfer mode (optional);  

• Get the file(s) you want; and  

• Quit.  

Telnet (Remote Computing) 

Telnet or remote computing is telecommunication utility software, which uses available 

telecommunication facility and allows you to become a user on a remote computer. Once 

you gain access to the remote computer, you can use it for the intended purpose. The 

TELNET works in a very step by step procedure. The commands typed on the client 

computer are sent to the local Internet Service Provider (ISP), and then from the ISP to 

the remote computer that you have gained access. Most of the ISP provides facility to 

TELNET into your own account from another city and check your e-mail while you are 

travelling or away on business.  

The followings steps are required for a TELNET session  

• Start up the TELNET program;  

• Give the TELNET program an address to connect to (some really nifty TELNET 

packages allow you to combine steps 1 and 2 into one simple step!);  

• Make a note of what the "escape character" is;  

• Log in to the remote computer;  

• Set the "terminal emulation;"  

• Play around on the remote computer; and  

• Quit.  

 

WORLD WIDE WEB (WWW) 

WWW is the acronym for the World Wide Web. It is also commonly known as ‘The 

Web’. The WWW is hypertext based information retrieval tool. One can easily surf the 

Web by jumping from one document to another using the links in those documents. 

These documents can be in many formats, such as text, graphics, animation, sound and 

latest is video. They may also be a combination of all these. All the information on 

Internet are presented to the user as a document or more popularly known as Web Page. 

All these Web Pages are link to each other or even to section within a Web Page. And 

these links are known as Hyper Links. 

The tool used to view these Web Pages on Internet is known as Internet browser or 

simply browser. It is a software program specifically developed to extract information on 

user request from the Internet and present them as a Web Page to the viewer. There are 

several browsers available in the market. However the most popular are Internet Explorer 
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from Microsoft and Netscape from Netscape Inc. The process of using browser to view 

information on Internet is known as Browsing or Surfing. 

 

Fig. 33.2 

(a) Internet Address 

Just like every house, every office, every location has an address, every page on the 

Internet has a unique address. This address is used get the web page for user from 

Internet. 

Just as the address of a house or office is known as its postal address, the address on the 

Internet is known as URL (Uniform Resource Locator). A typical Internet address or 

URL would look like; 

http://www.nos.org/computers/internet/url.htm 

The URL locates a particular web Page, among all the computers connected to the 

Internet. The URL contains the components that specify the protocol, server, and 

pathname of an item. Let us examine the URL given above 

(http://www.nos.org/computers/internet/url.htm).  

The protocol is followed by a colon (http:), the server is preceded by two slashes 

(//www.nos.org), and each segment of the pathname is preceded by a single slash 

(/computers/internet/url.htm). A protocol is set of rules that tells the computer know 

how to interpret the information at that address. 

 

Fig. 33.3 

The first component, the protocol, defines the manner for interpreting computer 

information. Many Internet pages use HTTP (HyperText Transfer Protocol). Other 

common Internet protocols that one might come across are FTP (File Transfer Protocol), 
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NEWS (Usenet news groups protocol), and GOPHER (an alternative transfer protocol). 

Gopher protocol is mostly out of date now.  

The second component, the server (www.nos.edu), identifies the computer system that 

stores the information you seek and is always preceded by two slashes. A server is a 

computer that has information stored on it and sends it to the client, when a request is 

made. Each server on the Internet has a unique address name whose text refers to the 

organization maintaining the server.  

The last component (/computers/internet/), defines the path within the Server where the 

requested item (url.htm) will be found. Most of the Web pages will have .htm or .html 

as their secondary or extension name. 

How to get connected to Internet 

There are various type of connectivity to get hook on to Internet. They all can be broadly 
classified into following category. 

Gateway Access 

 

Gateway Access is also known as Level-One connection. It is the access to the Internet 
from a network, which is not on the Internet. The gateway allows the two different types 
of networks to "talk" to each other. But the users of the Gateway Internet have limited 
access to the Internet. They might not be able to use all the tools available on Internet. 
The local Internet Service Provider (ISP) normally defines this limitation.  

Good example of network with Level One connectivity within India is that of VSNL 

(Videsh Sanchar Nigam Limited). All access to Internet from India are through VSNL 

gateway. 

 

Fig. 33.4 

Dial-up Connection 

‘Dial-up’ connection is also known as Level Two connection. This provides connection 

to Internet through a dial-up terminal connection. The computer, which provides Internet 

access is known as ‘Host’ and the computer that receives the access, is ‘Client’ or 

‘Terminal’. The client computer uses modem to access a "host" and acts as if it is a 

terminal directly connected to that host. So this type of connection is also known as 

‘Remote Modem Access’ connection. And the host to which the client gets connected is 

actually connected to the Internet by a full time connection (See Leased Connection). 
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Fig. 33.5 

In dial-up connection to Internet, Host carries all the command that are typed on a client 

machine and forward them to Internet. It also receives the data or information from the 

Internet on behalf of the ‘Client’ and passes it to them. The client computer acts as a 

‘dumb’ terminal connected to remote host.  

This type of connection can further be divided into two categories. 

Shell Connection 

In this type of Internet Connection, the user will get only textual matter of a Web Page. 

This connection does not support Graphics display. However the user will be able to surf 

the Internet, do FTP, receive mail. Shell Accounts were the only type of Internet access 

available for many years before the Internet entered in to the world of graphics and 

became more users friendly.  

TCP/IP Connection 

Today’s graphical World Wide Web browsers provide easier access with multimedia 

sound and pictures. The major difference between Shell and TCP/IP account is that, Shell 

account can only display text and does not support graphics display, whereas TCP/IP can 

display both. Hence it is more popular Internet connection. Shell accounts are slowly 

phasing out from the Internet scenario. 

To access any of these dial-up accounts you need the followings;  

• Computer  

• Modem  

• Telephone Connection  

• Shell or TCP/IP account from the ISP  

• Internet client software such as Internet browser.  

Leased Connection 

Leased connection is also known as direct Internet access or Level Three connection. It is 

the secure, dedicated and most expensive, level of Internet connection. With leased 

connection, your computer is dedicatedly and directly connected to the Internet using 

high-speed transmission lines. It is on-line twenty-four hours a day, seven days a week. 

Leased Internet connections are limited to large corporations and universities who could 

afford the cost.  
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PART 2 

Introduction to HTML 

HTML (Hypertext Markup Language) is  used to  create document on  the World Wide  

Web.  It  is  simply a collection of certain key words called ‘Tags’ that are helpful in 

writing the document to be displayed using a browser on  Internet. 

It  is  a platform independent language that can be  used on  any platform such as 

Windows, Linux, Macintosh, and so  on.  To display a document in web  it is essential to 

mark-up the different elements (headings, paragraphs,  tables, and so  on)  of  the 

document with the HTML  tags. To view  a mark-up document, user has to  open the  

document in  a browser. A  browser understands and interpret the HTML tags, identifies 

the structure of the document (which part are which) and makes decision about 

presentation (how  the parts look)  of the document. 

HTML also provides tags to  make the document look  attractive using graphics, font size  

and colors. User can make a link to the other document or  the different section of the 

same document by  creating Hypertext Links also known as Hyperlinks. 

OBJECTIVES

1. After  going through this lesson, you  would be  able to  : 

2. create, save and view  a HTML document 

3. format  a web  page using section heading tags 

4. describe Ordered and Unordered lists 

5. explain graphics in  HTML document 

6. describe hypertext links and making text/image links 
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CREATING, SAVING   AND  VIEWING  A  HTML DOCUMENT 

Creating a HTML document 

The  essential tags that are required to  create a HTML document are: 

<HTML>.............</HTML> 

 

<HEAD>.............</HEAD> 

<BODY>.............</BODY> 

HTML  Tag   <HTML> 

The  <HTML> tag  encloses all other HTML tags and associated text within your 

document. It  is  an optional tag. You  can create an HTML document that omits these 

tags, and your browser can still read it and display it.  But it is always a good  form to 

include the start and stop tags. 

The  format is: 

<HTML> 

Your Title and Document (contains text with HTML tags) goes  here 

</HTML> 

Most HTML tags have two  parts, an opening tag  and closing tag. The closing tag  is 

the same as the opening tag, except for the slash mark e.g </HTML>. The slash mark 

is always used in closing tags. An  HTML  document has two  distinct parts HEAD  

and BODY.The  Format is: 

<html> 

<HEAD> 

............. 

............. 

</HEAD> 

<BODY> 

............. 

............. 

</body> 

</html> 
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Head tag 

<head> 

HEAD tag comes after the HTML start tag. It contains TITLE tag to give the 

document a 

 title that displays on the browsers title bar at the top. 

The  Format is: 

<HEAD><TITLE> 

Your  title goes  here 

</TITLE></HEAD> 

BODY Tag  <BODY> 

The BODY tag contains all the text and graphics of the document with all the HTML 

 tags that are used for  control and formatting of the page. The  Format is: 

<BODY> 

Your Document goes here 

</BODY> 

An HTML document, web page can be created using a text editor, Notepad or  

WordPad. All the HTML documents should have the extension .htm or  .html. It  

require a web  browser like  Internet Explorer or  Netscape Navigator/Communicator  

to  view  the document. 

Follow the steps to create and view in browser: 

Step-1: Open text editor Notepad  

 (Click on Start →  All Programs→ Accessories Notepad) 

Step-2:  Enter the following lines of code: 

<HTML> 

<HEAD><TITLE>My first Page</TITLE></HEAD> 

<BODY> 

WELCOME TO MY FIRST  WEB  PAGE 

</BODY> 

</HTML> 

Step-3:  Save the file as myfirstpage.html (go to File-Save As- give File  name: 
myfirstpage.html-choose save as type: All Files-click save) 

Step-4:   Viewing document in web browser (open Internet Explorer-click on File-Open-Browse-
select the file myfirstpage.html-click open-click ok) 
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Attributes (Sub tags) used with <BODY> 

BGCOLOR: 

 Used to set the background color for the document 

Example: 

<BODY  BGCOLOR="yellow"> Your  document text goes  here. 

</BODY> 

TEXT:  

Used to set the color of the text of the document 

Example: 

<BODY TEXT="red"> 

Document text changed to red  color 

</BODY> 

 

MARGINS:  

Set the left hand/right hand margin of the document 

 

LEFTMARGIN: 

 Set the left hand margin of the document 

Example: 

<BODY LEFTMARGIN="60"> 

This document is  indented 60  pixels from the left  hand side of the page. 

</BODY> 

TOPMARGIN:  

Set the left hand margin of the document 

Example: 

<BODY TOPMARGIN="60"> 

This document is indented 60 pixels from the top o f  the page. 

</BODY> 
 

BACKGROUND:   

It is used to point to an image file (the files with an 

extension .gif, .jpeg) that will be used as the background of 

the document. The image file will be tiled across the 

document. 

Example: 

 

<BODY BACKGROUND="filename.gif"> Your  

document text goes  here 
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</BODY> 

Example Html Program 
<HTML> 

<HEAD> 

<TITLE> 

Use  of Attributes with the Body  Tag 

</TITLE> 

</HEAD> 

<BODYBACKGROUND="computer.gif"  text="blue" 

TOPMARGIN  ="75" 

LEFTMARGIN="75"> 

Your  document text will be indented 75  pixels from the 

left  hand and 75  pixels from the top  of the page. The 

background image computer.gif will be tiled across the 

document. Your  image and HMTL  document should 

present at the same place. 

</BODY> 

</HTML> 

Container and Empty Tags 

All HTML  tags are enclosed in  angle brackets ‘<’ and ‘>’ i.e. Opening Tag:  

<HTML>  and  closing tag: </HTML> same  as opening tag  except a / (slash) 

mark. Tags are not case-sensitive i.e.  there is  no  difference in  small and capital 

letters in  tags. 

There are two  types of tags: 

1.  Container  Tags:  

Tags which have both the opening and closing i.e.  <TAG>  and </TAG> are 

called container tags. They  hold the text and other HTML  tags in  between the 

tags. The  <HTML>,  <HEAD>, <TITLE>  and <BODY>  tags are all  container 

tags. 

Example: 

<TAG>  this is  a container tag. It  holds both the text and 

HTML tag  </TAG> 

2.  Empty Tags: 

 Tags, which have only  opening and no ending, are called empty tags. The  

<HR>,  which is  used to  draw Horizontal, rule across the width of the document, 

and line break <BR>  tags are empty tags. 

 

 

FORMATTING WEB PAGE 

HTML tags used for formatting a web  page are:  

SECTION HEADING: <H1>.............<H6> 

HTML has six header tags <H1>, <H2>...........<H6> used to specify section 

headings. Text  with header tags is displayed in larger and bolder fonts than the 
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normal body text by  a web  browser. Every header leaves a blank line  above and 

below it  when displayed in  browser. 

Example: An HTML document, headings.html shows the  different section 

headings 

<HTML> 

<HEAD><TITLE>Section Heading</TITLE></HEAD> 

<BODY> 

<H1>  This is Section Heading 1 </H1> 

<H2>  This is Section Heading 2 </H2> 

<H3>  This is Section Heading 3 </H3> 

<H4>  This is Section Heading 4 </H4> 

<H5>  This is Section Heading 5 </H5> 

<H6>  This is Section Heading 6 </H6> 

</BODY> 

</HTML> 

Using paragraph tag: <P> 

This tag   <P>  indicates a paragraph, used to  separate two paragraphs with a 

blank line.Example: 

<P>  Welcome to  the world of HTML </P> 

<P>  First paragraph. 

Text  of First paragraph goes  here </P> 

Output: 

Welcome to  the world of HTML 

First paragraph. Text  of First paragraph goes  here 

Here, two  paragraphs are separated with a line. But web  browser ignores the line  

breaks in  the second paragraph that can be controlled by  putting <BR>  tag. 

Using Line Break Tag: <BR> 

The  empty tag <BR>  is  used, where the text needs to  start from a new   line  

and not continue on  the same line. To  get  every sentence on  a new  line, it  is  

necessary to  use a line  break. 

Example: 

<BODY> 

PICT Institute of COmputer Schooling <BR> Link ,Road <BR> 

Abbottabad 
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</BODY> 

Output: 

PICT Institute of COmputer Schooling  

Link ,Road  

Abbottabad  

Using Preformatted Text Tag: <PRE> 

<PRE>   tag can be used, where it requires total control over spacing and line   

breaks such as typing a poem. Browser preserves your space and line  break in the 

text written inside the tag. 

Example: 

<PRE> 

Professional Institute of  

Computer 

Training Abbottabad 

</PRE> 

Output: 

Professional Institute of  

Computer 

Training Abbottabad 

Example: 

<HTML> 

<HEAD><TITLE>Use  of Paragraph, Line  break and preformatted text Tag 

</TITLE></HEAD> 

<BODY> 

HTML Tutorial 

<P> 

HTML stands for  Hypertext Markup Language 

It is used for creating web  

page. It is very  simple and 

easy to learn. 

</P> 

HTML stands for  Hypertext Markup Language.<BR> 

It is  used for  creating web  page. It is  very  simple<BR> 

and easy to  learn.<BR> 
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</P> 

<PRE> 

HTML stands for  Hypertext Markup Language 

It is  used for  creating web  page. It is  very  simple and easy to  learn. 

</PRE> 

</BODY> 

</HTML> 

Using Horizontal Rule Tag: <HR> 

An empty tag  <HR>  basically used to  draw lines and horizontal rules. It can be 

used to  separate two  sections of text. 

Example: 

<BODY> 

Your  horizontal rule goes  here. <HR> The  rest of the text goes  here. 

</BODY> 

Output: 

Your  horizontal rule goes  here.. 

The  rest of the text goes  here 

<HR>  accepts  following attributes: 

  SIZE: Determines the thickness of the horizontal rule. The value is  given as a 

pixel  value. 

Example: <HR SIZE="3"> 

  WIDTH: Specifies an exact width of HR in  pixels, or  a relative width as 

percentage of the document width. 

Example: <HR WIDTH="50%">, horizontal rule a width a 50 percent of the 

page width. 

ALIGN:  Set  the alignment of the rule to  LEFT,  RIGHT  and CENTER. It  is  

applicable if it  is  not equal to  width of the page. 

NOSHADE: If a solid bar is required, this attribute is used; it  specifies that the 

horizontal rule should not be  shaded at all. 

COLOR: Set  the color of the Horizontal rule. 

Example: <HR  COLOR="BLUE"> 

<HR  ALIGN=''CENTER'' WIDTH=''50%''  SIZE=''3"  NOSHADE 

COLOR="BLUE"> 

Character Formatting Tags 
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The character formatting tags are used to specify how  a particular text should be  

displayed on  the screen to  distinguish certain characters within the document. 

The most common character formatting tags are: 

§ Boldface <B>:  displays text in  BOLD 

Example: Welcome to  the <B>  Internet  World </B>OR<strong>  Internet  

World </strong>  Output:  Welcome to  the Internet World 

§ Italics <I>:  displays text in  Italic 

Example: Welcome to  the <I> Internet  World </I>Or<EM> Internet  World 

</EM>  Output:  Welcome to  the Internet World 

§ Subscript <SUB>: displays text in Subscript 

§ Superscript <SUP>: displays text in  Superscript 

§ Small <SMALL>: displays text in smaller font as compared to  normal 

font 

§ Big  <BIG>:   displays text in  larger font as compared to normal font 

§         TYPEWRITER TAG <tt>Improved!</tt> 

§         Citation Tag: <cite>Citation</cite> 

§         Emphesis: <em>Emphasized text</em> 

§ Font Colors and Size:<FONT> 

By using <FONT>  Tag one  can specify the colors, size  of the text. 

Example: <FONT>  Your  text goes  here </FONT> 

Attributes of  <FONT> are: 

COLOR: Sets  the color of the text that will  appear on  the screen. It can be  set 

by  giving  the value as #rr0000 for  red(in  RGB  hexadecimal format), or  by  

name. 

Example: <FONT  COLOR="RED"> Your  text goes  here </ FONT> 

SIZE: Sets the size  of the text, takes value between 1 and7, default is  3.  Size  

can also be  set relative to  default size for  example;  SIZE=+X, where X is  any 

integer value and it will  add with the default size. 

Example: <FONT SIZE=5> Font Size  changes to 5 </FONT> 

<FONT  SIZE=+2> Font Size  changes to 5 i.e.  default size  (3)±2</FONT> 

FACE:  Sets the normal font type, provided it is installed on the user’s machine. 

Example: <FONT  FACE="ARIAL"> the text will be displayed in  

Arial</FONT> 

<HTML> 

<HEAD> 

<TITLE> 
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Use  of Character Formatting Text  Tags 

</TITLE> 

</HEAD> 

<BODY> 

<H1><I> Welcome to  the world of Internet</I></H1> It is a 

<FONT  COLOR="BLUE" SIZE="4"> 

<U>Network of Networks</U> 

</FONT> 

</BODY> 

</HTML> 

 

 

 

 

Using Some Special Characters 

There are certain special characters that can be  used while creating document. 

Following are some special character: 

 

 

 

 

 

All these special character must be  ended with a semicolon; 

 

USING  LIST  IN  WEB  PAGE 

 

HTML Supports several ways of arranging items in lists. The  most commonly 

used are: 

Ordered List  (Numbered List) 

Unordered List  (Bulleted List)  

Ordered List  <OL> 

Symbols Entity 

©, ® &copy, &reg 

¼, ½,  ¾ &frac14, &frac12, &frac34 

÷, <, >, ≤,≥ &divide, &lt,  &gt,  &le,  

&ge 
& &amp 

♣♠♥  &spades, &clubs, &hearts 
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Ordered list  also called as Numbered list, is  used to  present a numbered list  of 

item in  the order of importance or  the item (paragraph) is  marked with a 

number. 

An ordered list must begin with the <OL> followed by  an <LI> 

list item tag. 

Example: An HTML document orderedList.html shows the  use of 

Ordered List 

<HTML> 

<HEAD><TITLE> 

An  Ordered List 

</TITLE></HEAD> 

<BODY> 

<H1><U> Various Terms Used In  Internet</U></H1> 

<OL> 

<LI> WWW-World Wide  Web 

<LI> URL-Uniform Resource  Locator 

<LI> HTTP-Hypertext Transfer  Protocol 

<LI> FTP-File Transfer  Protocol 

<LI> HTML-Hypertext Markup Language 

</OL> 

</BODY> 

</HTML> 

Attributes of  <OL>  tag: 

 COMPACT: render a list  in  compact form. 

  TYPE  : allows marking list  items with different types. By default the list  Item 

markers are set to numbers 1,2,3… so on. 

Other values of TYPE attribute are: 

 

Attribute 
 

Description 

Type  = A Capital letter eg.  A, B,  C……… 

Type  = a Small letter eg.  a, b,  c,……… 

Type  = I Uppercase Roman Numbers eg.  I, II, III…… 

Type  = i Lowercase Roman Numbers eg.  i, ii,  iii…… 
 

Type  = 1 
 

eg.   1,  2,  3…………. 



Sardar azeem PICT 12 

AZEEM_AAG2000@YAHOO.COM  03135879331 

START: used for lists that need to start at values other than START  always 

specified in  default numbers, and is completed based on  TYPE  before display, 

For  example, If START  =5  it  would display either an ‘E’, ‘e’, ‘V’, ‘v’, or  ‘5’ 

based an TYPE  attribute. 

Nested Order List 

One  ordered list  might contain one  or  more ordered list  that is called as Nested 

Order lists. 

Example: An HTML document nested.html shows the  use of Nested 

Order Lists with attributes. 

<HTML> 

<HEAD> 

<TITLE> Use  of Nested Ordered Lists</TITLE> 

</HEAD> 

<BODY> 

<OL TYPE = A START =3> 

<LI> Fruits 

<OL TYPE = I> 

<LI> Apple 

<LI> MANGO 

<LI> Orange 

</OL> 

<LI> VEGETABLES 

<OL TYPE = I> 

<LI> Brinjal 

<LI> Cabbage 

<LI> Tomato 

</OL> 

</OL> 

</BODY> 

</HTML> 

Unordered List <UL> 

Unordered List  also called as bulleted list, used to  present list of items marked 

with bullets. An unordered list starts with in <UL> followed by <LI> (List Item) 

tag. Use  of <UL> is very similar to <OL> (ordered list). 
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Example: Use  of Unordered List  and Various Attributes 

<HTML> 

<HEAD> 

<TITLE>  Use  of Unordered List  </TITLE> 

</HEAD> 

<BODY> 

<UL> 

<LI> FRUITS</LI> 

<LI> Apple 

<LI> Mango 

<LI> Orange 

</UL> 

<LI> VEGETABLE 

<UL> 

<LI> Brinjal 

<LI> Cabbage 

<LI> Tomato 

</UL> 

</UL> 

</BODY> 

</HTML> 

Menu List: 

Used to create a menu list 

<menu> 

  <li>html</li> 

  <li>xhtml</li> 

  <li>css</li> 

</menu> 

Definition list. Unlike the lists we have seen earlier, the definition list 

marks its entries not with a bullet marker or a number, but by its pattern of 

indentation. 
 
 

The format for a definition list tag is: 
 
 

<dl> 

<dt> title1 
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<dd> definition1 

<dt> title2 

<dd> definition2 

: 

<dt> titleN 

<dd> definitionN 

</dl> 

USING  GRAPHICS IN  WEB  PAGE  <IMG> 

Images can be  placed in  a web  page by  using <IMG>  tag. There are many 

image formats available today, but the most widely used among 

them are gif  and jpeg. The  gif  format is  considered 

superior to  the jpeg  format for  its clarity and ability to  maintain 

the originality of an image without lowering its quality. Using 

tools such as GIF  constructor or  Adobe Photoshop images 

can be created. 

It is an empty tag (only  start tag, no  end tag)  and is  written as: 

<IMG  SRC  = image_URL> 

SRC  – Source of the image file 

image_URL – represents the image file  with its location. 

Example:  <IMG  SRC=file:///C:/NOSlogo.GIF> 

Here, image_URL =file:///C:/NOSlogo.GIF, it  means image is available in  the 

Hard Drive  C: on  the local hard disk. 

Example: <IMG  SRC  =http://planningcommission.nic.in/ 

images/planimg.jpg> 

Here image _URL is = http://planningcommission.nic.in/images/ planimg.jpg. 

The  image planimg.jpg, is  taken from the images 

directory of Planning Commission Web  Server ‘Planningcomm- ission.nic.in’. 

If the location of the image and web  page are in  the same place in  the same 

directory/path then it  is  simply written  <IMG SRC=NOSlogo.GIF> 

This SRC  attribute is mandatory for the <IMG>  tag. 

Other attributes  used with <IMG>  are:  - 

 ALIGN 

 HEIGHT AND WIDTH 

 VSPACE  and HSPACE 

 ALT 

 BORDER 

 

http://planningcommission.nic.in/
http://planningcommission.nic.in/images/
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ALIGN:  used to  set the alignment of the text adjacent to  the image. It  takes  

the following values: 

 ALIGN  =  LEFT  -  Displays image on  left  side and the subsequent text 

flows  around the right hand side of that image 

 ALIGN = RIGHT  - Displays the image on  the right side and the 

subsequent text flows  around the left  hand side of that image 

 ALIGN = TOP  - Aligns the text with the top  of the image 

 ALIGN = MIDDLE  - Aligns the text with the middle of the image 

 ALIGN=BOTTOM - Aligns the text with the bottom of the image 

By  default, the text is aligned with the bottom of  the image 

<HTML> 

<HEAD><TITLE> Use of IMG Tag With  its ALIGN Attribute</TITLE> 

</HEAD> 

<BODY><P><IMG  SRC=NOSlogo.GIF  ALIGN=TOP> Aligns the text with 

the Top  of the image</P> 

<P><IMG  SRC=NOSlogo.GIF ALIGN=MIDDLE> Aligns the text with the 

Middle of the image</P> 

<P><IMG  SRC=NOSlogo.GIF ALIGN=LEFT> 

Displays image on left side and the subsequent text flows around the right 

hand  side of that image. Displays image on  left  side and the subsequent text 

flows  around the right hand side of that image. Displays image on left side 

and the subsequent text flows around the right hand side of that image.</P> 

<P><IMG  SRC=NOSlogo.GIF ALIGN=RIGHT> 

Displays image on right side and the subsequent text flows around the left  

hand side of that image. Displays image on right side and the subsequent text 

flows around the left hand side of that image.</P> 

</BODY> 

</HTML> 

HEIGHT and  WIDTH 

Height and Width of an image can be  controlled by  using the 

HEIGHT and  WIDTH  attributes in  the <IMG>  tag  as follows: 

Example: <IMG  SRC=  NOSlogo.GIF HEIGHT=320 WIDTH=240> 

HSPACE and VSPACE 

White space around an image can be  provided by using HSPACE (Horizontal 

Space) and VSPACE  (Vertical Space) attributes of the 

<IMG>  tag. These attributes  provide the space in  pixels 

Example: <IMG  SRC=NOSlogo.GIF  VSPACE=30 HSPACE=25> 
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ALT (Alternative Text) 

This attribute is used to give alternative text that can be displayed in  place of the 

image. This is  required when the user needs to stop display of images while 

retrieving a document in  order to make the retrieval faster, or  when the browser 

does not support graphics. It is also used a tool  tips – displaying description of 

the image when the mouse is  over  the image. 

Example: <IMG  SRC=NOSlogo.GIF ALT = "NOSLogo"> 

BORDER 

Border around the image can be  controlled by  using BORDER attribute of 

<IMG>  tag. By  default image displays with a thin border. To change the 

thickness or  turn the border off, the value in  pixels should set to  BORDER 

attribute. 

Example: <IMG  SRC=NOSlogo.GIF BORDER=0> BORDER =0  to  Turn 

the Border off 

Example: <IMG  SRC=NOSlogo.GIF BORDER=3> 

 

BORDER=3 to  make the border thickness to  3 

<HTML> 

<HEAD><TITLE> Use  of Image Attributes </TITLE></HEAD> 

<BODY> 

<IMG SRC=NOSLogo.GIF HSPACE=5 VSPACE=5 BORDER=5 ALT=NOS- 

LOGO  ALIGN=LEFT> 

Professional institute of computer training link road abbottabad 

Professional institute of computer training link road abbottabad 

Professional institute of computer training link road abbottabad 

</BODY> 

</HTML> 

Anchor Link to a Graphic 

With the anchor tag, you can also create a link to display a graphic file. When the 

anchor link is selected, it will download the image file and display the image by 

itself in an empty page. 

The simplest anchor link is to a file in the same directory/folder as the document 

that calls it. The format for creating a hypertext link to a graphic is the same as 

above for linking to another HTML document: 

<a href="filename.gif">text that responds to link</a> 

where filename.gif is the name of a GIF image file. 

Blink tag: 
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<blink>Text</blink> 

 

If you want blinking text, use this tag. 

The tag used is "blink"  

 

Example Code: 

<blink> blinking text tag</blink> 

 

Marquee tag in Html four types of marquee 

This is a discussion on Marquee tag in Html four types of marquee within the 

Programming forums, part of the Tutorials category; Marquee tag in Html, four 

types of marquee Open notepad and type html code as given 

<HTML> 
< HEAD> 
 
< TITLE> Marquee in Html </TITLE> 
 
< /HEAD> 
 
< BODY> 
 
< MARQUEE> Simple marquee in Html </MARQUEE> 
 
< BR><BR> 
 
< MARQUEE BEHAVIOR = SCROLL DIRECTION=RIGHT 
BGCOLOR ="#0000ff"> <FONT COLOR="#ffffff"><B> 
Scrolling Right </FONT></B></MARQUEE> 
 
< BR><BR> 
< MARQUEE BEHAVIOR = ALTERNATE 
BGCOLOR="#9A3334"><FONT COLOR= "#ffffff"><B> 
This Alternate Marquee <B></FONT></MARQUEE>  
< BR><BR> 
< DIV ALIGN= "CENTER"> <MARQUEE BGCOLOR 
="#9A3334" SCROLLAMOUNT ="1"  
DIRECTION ="up" LOOP = "TRUE" WIDTH ="40%"> 
<CENTER>  
< FONT COLOR="#ffffff" SIZE = "+2"> <strong> 
Scrolling Your Text  
Upwards...<br> </MARQUEE></DIV> 
 
< /BODY> 
< /HTML> 
 

Address Fasters and Email Link 

ADDRESS Tag 

The HTML address element provides contact information on a page. It could be 

used, for example, to provide information about the enterprise behind the website, 

the author of a specific article or the author of the website itself. The content of 
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this block element could include names, company names, phone numbers, postal 

or zip codes, e-mail addresses, etc. 

<address> 

Author: Sardar Azeem  

Lower Malik Purra 

CP Abbottabad 

(512) 411-7433 

</address> 

LINK TO EMAIL 

Having a link that allows visitors to send email from your website can be a great 

addition to your site, making it easy for your visitors to send questions or 

comments. 

 

There is a special link for this action.  

Email links are done much the same as links to other pages, using the  

<a href> tag. 

<a href="azeem_aag2000@yahoo.com">Email Me</a> 

<a href=" azeem_aag2000@yahoo.com?subject=SweetWords"> 

Send Email</a> 

Table In Html 

The HTML table element inserts a table in the document. Tables are a very useful 

and powerful feature of the HTML language, as they give a solution for inserting 

any type of tabulated data in the document. 

This element is the main container of a table, but many other elements are needed 

to define a table correctly. Other elements that constitute a table are: 

Rows (HTML tr element) 

Cells (HTML td element) 

Header cells (HTML th element) 

Caption or title (HTML caption element) 

An HTML table can be basically considered as a set of rows containg cells and 

not backwards. This is because the HTML tr element are designed to contain cell 

elements (HTML td element and HTML th element). 

A table can be divided horizontally, defining these sections: 

Header (HTML thead element) 

Body or bodies (HTML tbody element) 

Footer (HTML tfoot element) 

Besides, columns can be thematically grouped using the HTML colgroup element. 

Finally, the HTML col element can be used to apply style attributes to all cells in 

a number of consecutive columns at once. 

Note that the "align" attribute for this element has been deprecated in HTML 4.01 

in favor of style sheets. It's use is no longer recommended. 

http://www.htmlquick.com/reference/tags/tr.html
http://www.htmlquick.com/reference/tags/td.html
http://www.htmlquick.com/reference/tags/th.html
http://www.htmlquick.com/reference/tags/caption.html
http://www.htmlquick.com/reference/tags/tr.html
http://www.htmlquick.com/reference/tags/td.html
http://www.htmlquick.com/reference/tags/th.html
http://www.htmlquick.com/reference/tags/thead.html
http://www.htmlquick.com/reference/tags/tbody.html
http://www.htmlquick.com/reference/tags/tfoot.html
http://www.htmlquick.com/reference/tags/colgroup.html
http://www.htmlquick.com/reference/tags/col.html
http://www.htmlquick.com/reference/deprecated.html
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Example 1 

<table summary="Representation of how the pages of the website work in 

different versions of Internet Explorer"> 

<caption>Compatibility of the website in Internet Explorer</caption> 

<tr> 

<th>Name</th> 

<th>4.0</th> 

<th>5.0</th> 

<th>6.0</th> 

</tr> 

<tr> 

<td>index.html</td> 

<td>Ok</td> 

<td>Ok</td> 

<td>Ok</td> 

</tr> 

<tr> 

<td>fullfunc.html</td> 

<td>Bad</td> 

<td>Partial</td> 

<td>Ok</td> 

</tr> 

<tr> 

<td>nofunc.html</td> 

<td>Ok</td> 

<td>Ok</td> 

<td>Ok</td> 

</tr> 

<tr> 

<td>panel.html</td> 

<td>Bad</td> 

<td>Partial</td> 

<td>Ok</td> 

</tr> 

</table> 

The table is expanded to add another browser. In this case the columns are 

grouped thematically (Internet explorer and Mozilla Firefox). A header (HTML 

thread element) and a body (HTML body element) are also defined. 

 

Example 2 

<table summary="Representation of how the pages of the website work in 

different versions of Internet Explorer and Mozilla firefox"> 

<caption>Compatibility of the website in IE and FF</caption> 

<colgroup></colgroup> 

<colgroup span="3"></colgroup>  

<colgroup span="2"></colgroup>  

<thead> 

<tr> 

<th scope="row">Browser</th> 

<th scope="col" colspan="3">Internet Explorer</th> 

<th scope="col" colspan="2">Mozilla Firefox</th> 

</tr> 

<tr> 

<th scope="col">Name</th> 

<th scope="col">4.0</th> 

<th scope="col">5.0</th> 

<th scope="col">6.0</th> 

http://www.htmlquick.com/reference/tags/thead.html
http://www.htmlquick.com/reference/tags/thead.html
http://www.htmlquick.com/reference/tags/tbody.html
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<th scope="col">2.0</th> 

<th scope="col">3.0</th> 

</tr> 

</thead> 

<tbody> 

<tr> 

<td>index.html</td> 

<td>Ok</td> 

<td>Ok</td> 

<td rowspan="4">Ok</td> 

<td>Ok</td> 

<td rowspan="4">Ok</td> 

</tr> 

<tr> 

<td>fullfunc.html</td> 

<td>Bad</td> 

<td>Partial</td> 

<td>Partial</td> 

</tr> 

<tr> 

<td>nofunc.html</td> 

<td>Ok</td> 

<td>Ok</td> 

<td>Ok</td> 

</tr> 

<tr> 

<td>panel.html</td> 

<td>Bad</td> 

<td>Partial</td> 

<td>Partial</td> 

</tr> 

</tbody> 

</table> 

 

 

Meta Tags in Html 

<META> tags. This HTML syntax was created to allow "meta" or "extra" information to 

be embedded in a web page, in the part that is not displayed by the web browsers. There 

are many other types of META tags. 

The place that these tags go are within the <HEAD> ... </HEAD> part of your HTML 

document. 

META REFRESH for auto advancing of web 
pages 

 

 

The first type of META tag allows you to write HTML that will display your web page, wait an 

arbitrary number of seconds, and then 
automatically advance to another page or URL. Why would you even want to do such a thing? 

 

 

●      Pages that have moved. As a web site designer, you should strive to avoid your visitors 

striking the dreaded Error 404 Site Not Found message. Often you may create a web site 

available on the web, and then because you re-design the site, the file has been moved to a 

different folder/directory (see Swiss Web Knife), or moved to another web server (see M2C), or 

is just no longer made available (see Math Software Evaluations). It is nice to leave a page that 

offers a link to the newly named or moved site, but with the META tag, you can have it jump 

there automatically. 

http://www.mcli.dist.maricopa.edu/knife.html
http://www.mcli.dist.maricopa.edu/m2c/
http://www.mcli.dist.maricopa.edu/proj/sw/math/
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●      Timed Slide Shows You may create a series of web pages that each sit for say 10 seconds 

before automatically advancing to 

another web page, like a kiosk (see 1996 League of Innovation Conference Web Display) 

●      Opening Sequences Many web sites now are designed to load a quick opening page, 

perhaps with a small logo, that pauses a few seconds before jumping automatically to a more 

comprehensive page. This presents a more eye-pleasing introduction, especially if the main page 

is "busy", like the opening credits to a movie. 

<head> 

<title>My page title</title> 

<META HTTP-EQUIV="REFRESH" CONTENT="X; URL=newpage_or_URL.html"> 

</head> 

1.  First, you will need to get a copy of a colorful Volcano graphic image. 

     Put this image inside of your pictures folder/directory with your other image files. 

2.  Change the name of the HTML file index.html to index1.html 

3.  Using your text editor, open all of your HTML files, and change every link to file index.html 

to read index1.html. 

This occurs twice in every page, at the top of the page 

 

 

<a href="index.html">Index</a> / 

 

which should be changed to read: 

 

 

<a href="index1.html">Index</a> / 

 

The second place is at the bottom of every page, 

 

<address> 

<b><a href="index.html">Volcano Web</a> : 

 

which should be changed to read: 

 

<address> 

<b><a href="index1.html">Volcano Web</a> : 

4.  Now we will create a new page to replace the index.html page we had before. We will first 

construct it and verify the HTML before inserting the META tag (it is difficult to test your 

pages if it keeps moving every time you load it!). Using your text editor, create a new HTML 

file that looks like: 

<html> 

<head> 

<title>Volcano Web</title> 

</head> 

<BODY BGCOLOR=#000000 TEXT=#FFFFCC LINK=#33CCFF VLINK=#FF6666> 

<!-- first table centers all content on any browser window size --> 

<table border=0 width=100% height=100%> 

<tr> 

<td valign=middle align=center> 

 

<!-- Second table stretches the word "volcano!" across the width of the screen -- 

> 

<table border=0 width=100%> 

<tr> 

<td width=12% align=center><font face="verdana,helvetica,arial" 

size=+4><b>v</b></font></td> 

<td width=12% align=center><font face="verdana,helvetica,arial" 

size=+4><b>o</b></font></td> 

<td width=12% align=center><font face="verdana,helvetica,arial" 

size=+4><b>l</b></font></td> 

<td width=12% align=center><font face="verdana,helvetica,arial" 

size=+4><b>c</b></font></td> 

<td width=12% align=center><font face="verdana,helvetica,arial" 

size=+4><b>a</b></font></td> 

<td width=12% align=center><font face="verdana,helvetica,arial" 

size=+4><b>n</b></font></td> 

<td width=12% align=center><font face="verdana,helvetica,arial" 

size=+4><b>o</b></font></td> 
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<td width=12% align=center><font face="verdana,helvetica,arial" 

size=+4><b>!</b></font></td> 

</tr> 

</table> 

 

<p> 

<a href="index1.html"> 

<IMG SRC="../pictures/cover.gif" ALT="volcano!" WIDTH="206" HEIGHT="186" 

BORDER="0"></a> 

<p> 

<font face="verdana,helvetica,arial" size=2><a href="index1.html">enter</a></font> 

</td> 

</tr> 

</table> 

</body> 

</html> 

 

 

 

 

 

 

 

 

 
 
META Descriptor tags 

 

 

You are doing all of this hard work to learn HTML and create web pages. Ultimately, you 

probably want people to be able to find 

them among the other 10 gizillion pages out there. META tags allow you to add extra 

information that will help identify your web page when people use Internet searches. 

 

<META name="description" content="The string of text is a really good description of 

this web page. Perhaps a second sentence would help as well."> 

 

Now we will add the two descriptor META tags to the main entry page for your Volcano Web 

site. For your own work, you may add these to each page so that it has unique content and 

keywords. 

 

 

1.  Open the index.html file in your text editor. 

2.  After the portion of the HEAD tag that reads: 

 

 

<META HTTP-EQUIV="REFRESH" CONTENT="2; URL=index1.html"> 

 

add these two additional META tags: 

 

 

<META name="description" content="A mini lesson about the wide world of volcanoes 

as an example for the Writing HTML tutorial"> 

<META  name="keywords" content="HTML, volcano, learn, web page, earth, 

mars, Mount St, Helens, Long Valley, Pliny"> 

 

3.  Save the HTML file and Reload in your Web browser. 

 

Frameset in HTML  
 

 

A web page that uses frames consists of a "master" HTML document, that we'll call the 

"blueprint" for the layout, that defines the framesets, or the arrangement of the framed areas on 

the page. This is the document that loads the frame structure and the one that represents the 
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URL for the framed page. 

 

 

You can devise many ways to slice and dice the web page area: 
 

 
 

 

 

Each of the sub-divided areas will be associated with an HTML file that defines what goes into 

that particular box. Therefore, the first step is to sketch out how the page should be divided up 

and how much relative space each area needs. 

Once you have a visual idea, you must define it in terms of rows and columns, similar to the 

approach for designing tables . Start working from the upper left to the lower right. 

Looking at the sketches above, example 1 is made of 2 rows and example 2 contains 2 columns. 

Example 3 can be seen either as two rows, each containing two columns, or 2 columns, each of 

which contains two rows. 

Are you still with us? Example 5 can be seen as three rows, where the middle row has two 

columns. So is Example 6 

except that first row is the one with two columns. 

Now, look carefully at example 7. It is divided into 2 rows. The lower row contains 2 columns, 

each of which contains two rows of differing proportions 

Example NO1 

<html> 

<head> 

<title>Title of this Whole Page</title> 

</head> 

 

<FRAMESET ROWS/COLS="X,Y,...Z"> 

<FRAME SRC="frame_source1.html"> 

<FRAME SRC="frame_source2.html"> 

: 

: 

<FRAME SRC="frame_sourceN.html"> 

</frameset> 

<NOFRAMES> 

This is what someone would see who does not have a web browser that can display frames. 

</NOFRAMES> 

</html> 

Example No 2 

<html> 

<head> 

<title>A More Complex Framed Page</title> 

</head> 

<!-- two main rows --> 

<FRAMESET ROWS="120,*> 

 

<!-- row 1 is a single doc --> 

<FRAME SRC="row1.html"> 

 

<!-- two main columns in row 2 --> 

<FRAMESET COLS="75%,25%> 
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<!-- two rows in first column --> 

<FRAMESET ROWS="60%,40%> 

<FRAME SRC="row2col1row1.html"> 

<FRAME SRC="row2col1row2.html"> 

</frameset> 

 

<!-- two rows in second column --> 

<FRAMESET ROWS="100,*> 

<FRAME SRC="row2col21row1.html"> 

<FRAME SRC="row2col21row2.html"> 

</frameset> 

</frameset> 

</frameset> 

<NOFRAMES> 

This is what someone would see who does not have a web browser that can display frames 

</NOFRAMES> 

</html> 

 

Forms In HTML 

 
Used to create the forms to website form is the most important input and output tool. 

Form uses the following tag  

 

<form action="[url for server program]" method="GET/POST"> 

: 

: 

(form elements) 

: 

</form> 
 

HTML for the basic web form elements 

•     text fields 

•     password fields 

•     text area fields 

•     radio buttons 

•     checkboxes 

•     menu selections 

•     buttons 

Text Input Elements (type="text") 
 

 

... are used to create one line fields that viewers can type text. The default width is 20 characters, 

and you can create fields of other sizes by the value in the size option. You can limit the number 

of characters by the value of the MAXLENGTH option. Text input fields will be empty when 

the page loads, unless you provide an initial text string for its VALUE option. 

 

A text field named "text1" that is 30 characters wide. 

<input type="text" name="text1" size="30"> 

 

A text field named "text2" that is 30 characters wide but will only accept 20 characters. 

<input type="text" name="text2" size="30" maxlength="20"> 

 

A text field named "text3" that is 40 characters wide with default value. 

<input type="text" name="text3" size="40" value="We are not alone"> 

 

Password Input Elements (type="password") 
 

 

... are exactly the same as text input elements, except that when the viewer types in, they see 

"bullet" characters rather then the letter they are typing. Password text is scrambled during 

transmission and then unscramble when the form data is received at the server end 

 

A password field named "pass1" that is 30 characters wide. 

<input type="password" name="pass1" size="30"> 
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A password field named "pass2" that is 30 characters wide but will only accept 20 

characters. 

<input type="password" name="pass2" size="30" maxlength="20"> 

 

A password field named "pass3" that is 40 characters wide with default value. 

<input type="password" name="pass3" size="40" value="We are not alone"> 

 

Text Area Input Elements (type="textarea") 
 

 

... are text fields that have more than one line and can scroll as the viewer enters more text. The 

tag options define the size of the 

field by the number of rows and character columns. By adding the option WRAP=VIRTUAL, 

the text entered will automatically wrap at the right hand side of the field. You can also 

include default text to appear in the field. 
 

 

A textarea field named "comments" that is 45 characters wide and 6 lines high. 

<textarea name="comments" rows="6" cols="45" wrap="virtual"> The first time I ever 

saw a web page, I thought.... (continue) 

</textarea> 

 

Radio buttons (type="radio") 
 

 

... are sets of buttons that are linked so that only one among button in each sets is selected at a 

time; if you click one button, the others in the set are automatically de-selected. A set of radio 

buttons is defined by providing them the same name. The value sent in the web form is the 

value of the radio button that was last selected. Adding the option CHECKED to one of the 

buttons in a set will make that button highlighted when the page loads. 

4 radio buttons with default selection 

<input type="radio" name="food" value="hotdogs" checked> 

hotdogs are my favorite food<br> 

<input type="radio" name="food" value="hamburgers"> i like hamburgers<br> 

<input type="radio" name="food" value="steak"> steak is tasty<br> 

<input type="radio" name="food" value="beans"> beans are for veggie-lovers<br> 

 

hotdogs are my favorite food i like hamburgers 

steak is tasty 

beans are for veggie-lovers 

 

3 radio buttons with no default selection 

<input type="radio" name="spread" value="ketsup"> ketsup<br> 

<input type="radio" name="spread" value="mustard"> 

mustard<br> 

<input type="radio" name="spread" value="mayo"> 

mayonnaise<br> 

 

Check Boxes (type="checkbox") 
 

 

...are similar to radio buttons, but are not affected by other buttons, so you can have more than 

one in a group checked at a time. Note that every checkbox has a unique name. If there is no 

check in the box, clicking it will place an X or a check mark there. If the box is checked, 

clicking it again will remove the mark. The value sent in the web form is the value of the 

checkbox if it was selected; otherwise the value will be empty. Adding the option CHECKED 

to one of the buttons in a set will make that button highlighted when the page loads. 
 

4 check boxes with default selections 

<input type="checkbox" name="food1" value="hotdogs" checked> 

hotdogs are my favorite food<br> 

<input type="checkbox" name="food2" value="hamburgers"> i like hamburgers<br> 

<input type="checkbox" name="food3" value="steak" checked> 

steak is tasty<br> 

<input type="checkbox" name="food4" value="beans"> beans are for veggie-lovers<br> 

 

Menu Select (type="select") 
... provides drop-down menus that allow the viewer to choose one from a list of choices. The 

<OPTION>...</OPTION> tag defines the text that is displayed in the menu. The value of 
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the option last selected is returned when the form data is transmitted. Adding the 

SELECTED option indicates which element is displayed initially when the page loads; if this 

is not provided, the first item is selected by default. 

A four item select menu with the third item selected initially 

<select name="cheeses"> 

<option value="colby"> Colby from Ohio</option> 

<option value="sharp"> Sharp Cheddar from Oregon</option> 

<option value="swiss" selected> Holy Cheese from 

Switzerland</option> 

<option value="longhorn" > English Longhorn</option> 

</select> 

 
Submit and Reset (type="submit" and type="reset") 

 

 

... creates buttons on the form. The Submit button tells the web browser to gather up all the 

selections, values, and entered text in the form elements and send it off to the place defined in 

the ACTION part of the form tag. The Reset button restores the form to its default state, how it 

looked when the viewer first entered the page. The VALUE option defines the text string that is 

placed on these buttons. 

Submit button 

<input type="submit" value="Send this form data now!"> 

 

 

 

Reset button 

<input type="reset" value="Clear the web form"> 

 

 

Example Program 

<HTML> 

<BODY> 

<FORM METHOD=POST ACTION=URL> 

NAME <INPUT TYPE=TEXTBOX><BR> 

FNAME <INPUT TYPE=TEXTBOX><BR> 

ADDRESS <INPUT TYPE=TEXTBOX><BR> 

CLASS <INPUT TYPE=TEXTBOX><BR> 

PH NUMBER <INPUT TYPE=TEXTBOX><BR> 

EMAIL<INPUT TYPE=TEXTBOX><BR> 

PASSWORD<INPUT TYPE=PASSWORD><BR> 

GENDER <BR> 

MALE<INPUT TYPE=RADIO><BR> 

FEMALE<INPUT TYPE=RADIO><BR> 

QUALIFICATIONS <BR> 

MATRIC<INPUT TYPE=CHECKBOX><BR> 

FA/FSC<INPUT TYPE=CHECKBOX><BR> 

BA/BSC<INPUT TYPE=CHECKBOX><BR> 

MA/MSC<INPUT TYPE=CHECKBOX><BR> 

COMMENTS<BR> 

<TEXTAREA ROWS=20 COLS=20>YOUR 

COMMENTS</TEXTAREA> 

<INPUT TYPE=SUBMIT><INPUT TYPE=SUBMIT> 

</FORM> 

</BODY> 

</HTML> 
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PART 3 

Introduction to DHTML 
DHTML is the art of combining HTML, JavaScript, DOM, and CSS. 

DHTML is NOT a Language 

DHTML stands for Dynamic HTML. 

DHTML is NOT a language or a web standard. 

To most people DHTML means the combination of HTML, JavaScript, DOM and CSS.  

According to the World Wide Web Consortium (W3C): 

"Dynamic HTML is a term used by some vendors to describe the combination of HTML, 

style sheets and scripts that allows documents to be animated."  

HTML 

The W3C HTML 4 standard has rich support for dynamic content:  

HTML supports JavaScript 

HTML supports the Document Object Model (DOM) 

HTML supports HTML Events 

HTML supports Cascading Style Sheets (CSS) 

DHTML is about using these features, to create dynamic and interactive web pages. 

 

JavaScript 

JavaScript is the most popular scripting language on the internet, and it works in all major 

browsers. 

DHTML is about using JavaScript to control, access and manipulate HTML elements. 

You can read more about JavaScript in the next chapter of this tutorial. 

 

HTML DOM 

The HTML DOM is a W3C standard. It describes the Document Object Model for 

HTML. 

The HTML DOM defines a standard way for accessing and manipulating HTML 

documents. 

DHTML is about using the DOM to access and manipulate HTML elements.  

You can read more about the HTML DOM in a later chapter of this tutorial. 
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HTML Events 

HTML events are a part of the HTML DOM. 

DHTML is about creating web pages that reacts to (user)events. 

You can read more about events in a later chapter of this tutorial. 

 

CSS 

CSS defines how to display HTML elements. 

DHTML is about using JavaScript and the HTML DOM to change the style and 

positioning of HTML elements. 

You can read more about CSS in a later chapter of this tutorial. 

JAVA SCRIPT INTRODUCTION 

JavaScript is THE scripting language of the Web. 

JavaScript is used in billions of Web pages to add functionality, validate forms, 

communicate with the server, and much more 

What is JavaScript? 

1. JavaScript was designed to add interactivity to HTML pages 

2. JavaScript is a scripting language 

3. A scripting language is a lightweight programming language 

4. JavaScript is usually embedded directly into HTML pages 

5. JavaScript is an interpreted language (means that scripts execute without 

preliminary compilation) 

6. Everyone can use JavaScript without purchasing a license 

What Can JavaScript do? 

1. JavaScript gives HTML designers a programming tool - HTML authors are 

normally not programmers, but JavaScript is a scripting language with a very 

simple syntax! Almost anyone can put small "snippets" of code into their HTML 

pages 

2. JavaScript can react to events - A JavaScript can be set to execute when 

something happens, like when a page has finished loading or when a user clicks 

on an HTML element 

3. JavaScript can manipulate HTML elements - A JavaScript can read and change 

the content of an HTML element 

4. JavaScript can be used to validate data - A JavaScript can be used to validate form 

input 

5. JavaScript can be used to detect the visitor's browser - A JavaScript can be used to 

detect the visitor's browser, and - depending on the browser - load another page 

specifically designed for that browser 

6. JavaScript can be used to create cookies - A JavaScript can be used to store and 

retrieve information on the visitor's computer 

Java Script Program Structure 
<html> 

< body> 

< h1>My First Web Page</h1> 

< p id="demo">My First Paragraph</p> 
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<script type="text/javascript"> 

document.getElementById("demo").innerHTML="My First JavaScript"; 

< /script> 

< /body> 

< /html> 

JavaScript Functions in <head> 
<html> 

<head> 
<script type="text/javascript"> 
function myFunction() 
{ 
document.getElementById("demo").innerHTML="My First JavaScript Function"; 
} 

< /script> 
< /head> 

<body> 

<h1>My Web Page</h1> 

<p id="demo">A Paragraph</p> 

<button type="button" onclick="myFunction()">Try it</button> 

</body> 
< /html> 

JavaScript Functions in <body> 
<html> 
<body> 

<h1>My Web Page</h1> 

<p id="demo">A Paragraph</p> 

<button type="button" onclick="myFunction()">Try it</button> 

<script type="text/javascript"> 
function myFunction() 
{ 

document.getElementById("demo").innerHTML="My First JavaScript Function"; 
} 
< /script> 

</body> 
< /html> 

 

 

 

 

 

 

 

 

Introduction to CSS 1 

A CSS (cascading style sheet) file allows you to separate your web sites (X)HTML 

content from it’s style. As always you use your (X)HTML file to arrange the content, but 

all of the presentation (fonts, colors, background, borders, text formatting, link effects & 

so on…) are accomplished within a CSS. 

At this point you have some choices of how to use the CSS, either internally or 

externally. 
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Internal Stylesheet 

First we will explore the internal method. This way you are simply placing the CSS code 

within the <head></head> tags of each (X)HTML file you want to style with the CSS. 

The format for this is shown in the example below. 

<head> 

< title><title> 

< style type=”text/css”> 

CSS Content Goes Here 

< /style> 

< /head> 

< body> 

With this method each (X)HTML file contains the CSS code needed to style the page. 

Meaning that any changes you want to make to one page, will have to be made to all. 

This method can be good if you need to style only one page, or if you want different 

pages to have varying styles. 

External Stylesheet 

Next we will explore the external method. An external CSS file can be created with any 

text or HTML editor such as “Notepad” or “Dreamweaver”. A CSS file contains no 

(X)HTML, only CSS. You simply save it with the .css file extension. You can link to the 

file externally by placing one of the following links in the head section of every 

(X)HTML file you want to style with the CSS file. 

<link rel=”stylesheet” type=”text/css” href=“Path To stylesheet.css” /> 

Or you can also use the @import method as shown below 

<style type=”text/css”>@import url(Path To stylesheet.css)</style> 

Either of these methods are achieved by placing one or the other in the head section as 

shown in example below. 

<head> 

< title><title> 

<link rel=”stylesheet” type=”text/css”href=”style.css” /> 

< /head> 

< body> 

or 

<head> 

< title><title> 

< style type=”text/css”> @import url(Path To stylesheet.css) </style> 

< /head> 

< body> 

By using an external style sheet, all of your (X)HTML files link to one CSS file in order 

to style the pages. This means, that if you need to alter the design of all your pages, you 

only need to edit one .css file to make global changes to your entire website. 

Here are a few reasons this is better. 

• Easier Maintenance 

• Reduced File Size 

• Reduced Bandwidth 

• Improved Flexibility 
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Cascading Order 

In the previous paragraphs, I have explained how to link to a css file either internally or 

externally. If you understood, than I am doing a good job. If not don’t fret, there is a long 

way to go before we are finished. Assuming you have caught on already, you are 

probably asking, well can I do both? The answer is yes. You can have both internal, 

external, and now wait a minute a third way? Yes inline styles also. 

Inline Styles 

I have not mentioned them until now because in a way they defeat the purpose of using 

CSS in the first place. Inline styles are defined right in the (X)HTML file along side the 

element you want to style. See example below. 

<p style=”color: #ff0000;”>Some red text</p> 

Some red text 

Inline styles will NOT allow the user to change styles of elements or text formatted this 

way 

So, which is better? 

So with all these various ways of inserting CSS into your (X)HTML files, you may now 

be asking well which is better, and if I use more than one method, in what order do these 

different ways load into my browser? 

All the various methods will cascade into a new “pseudo” stylesheet in the following 

order: 

1. Inline Style (inside (X)HTML element) 

2. Internal Style Sheet (inside the <head> tag) 

3. External Style Sheet 

As far as which way is better, it depends on what you want to do. If you have only one 

file to style then placing it within the <head></head> tags (internal) will work fine. 

Though if you are planning on styling multiple files then the external file method is the 

way to go. 

Users with Disabilities 

The use of external style sheets also can benefit users that suffer from disabilities. For 

instance, a user can turn off your stylesheet or substitute one of there own to increase text 

size, change colors and so on. For more information on making your website accessible 

to all users please read  

Power Users 

Swapping stylesheets is beneficial not only for users with disabilities, but also power 

users who are particular about how they read Web documents. 

Browser Issues 

You will discover as you delve farther into the world of CSS that all browsers are not 

created equally, to say the least. CSS can and will render differently in various browsers 

causing numerous headaches. 

CSS Syntax 

The syntax for CSS is different than that of (X)HTML markup. Though it is not too 

confusing, once you take a look at it. It consists of only 3 parts. 
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selector { property: value } 

The selector is the (X)HTML element that you want to style. The property is the actual 

property title, and the value is the style you apply to that property. 

Each selector can have multiple properties, and each property within that selector can 

have independent values. The property and value are separated with a colon and 

contained within curly brackets. Multiple properties are separated by a semi colon. 

Multiple values within a property are sperated by commas, and if an individual value 

contains more than one word you surround it with quotation marks. As shown below. 

body { 

background: #eeeeee; 

font-family: “Trebuchet MS”, Verdana, Arial, serif; 

} 

As you can see in the above code I have separated the color from the font-family with a 

semi-colon, separated the various fonts with commas and contained the “Trebuchet MS” 

within quotations marks. The final result sets the body color to light grey, and sets the 

font to ones that most users will have installed on there computer. 

I have changed the way I layout my code, but you can arrange it in one line if you 

choose. I find that it is more readable if I spread each property to a separate line, with a 2 

space indention. 

 

Inheritance 

When you nest one element inside another, the nested element will inherit the properties 

assigned to the containing element. Unless you modify the inner elements values 

independently. 

For example, a font declared in the body will be inherited by all text in the file no matter 

the containing element, unless you declare another font for a specific nested element. 

body {font-family: Verdana, serif;} 

Now all text within the (X)HTML file will be set to Verdana. 

If you wanted to style certain text with another font, like an h1 or a paragraph then you 

could do the following. 

h1 {font-family: Georgia, sans-serif;} 

p {font-family: Tahoma, serif;} 

Now all <h1> tags within the file will be set to Georgia and all <p> tags are set to 

Tahoma, leaving text within other elements unchanged from the body declaration of 

Verdana. 

There are instances where nested elements do not inherit the containing elements 

properties. 

For example, if the body margin is set to 20 pixels, the other elements within the file will 

not inherit the body margin by default. 

body {margin: 20px;} 

Combining Selectors 

You can combine elements within one selector in the following fashion. 
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h1, h2, h3, h4, h5, h6 { 

color: #009900; 

font-family: Georgia, sans-serif; 

} 

As you can see in the above code, I have grouped all the header elements into one 

selector. Each one is separated by a comma. The final result of the above code sets all 

headers to green and to the specified font. If the user does not have the first font I 

declared it will go to another sans-serif font the user has installed on their computer. 

Comment tags 

Comments can be used to explain why you added certain selectors within your css file. 

So as to help others who may see your file, or to help you remember what you we’re 

thinking at a later date. You can add comments that will be ignored by browsers in the 

following manner. 

/* This is a comment */ 

You will note that it begins with a / (forward slash) and than an * (asterisks) then the 

comment, then the closing tag which is just backward from the opening tag * (asterisks) 

then the / (forward slash). 

CSS Classes 

The class selector allows you to style items within the same (X)HTML element 

differently. Similiar to what I mentioned in the introduction about inline styles. Except 

with classes the style can be overwritten by changing out stylesheets. You can use the 

same class selector again and again within an (X)HTML file. 

To put it more simply, this sentence you are reading is defined in my CSS file with the 

following. 

p {  

font-size: small;  

color: #333333 

} 

Pretty simple, but lets say that I wanted to change the word “sentence” to green bold text, 

while leaving the rest of the sentence untouched. I would do the following to my 

(X)HTML file. 

<p> 

To put it more simply, this <span class=”greenboldtext”>sentence</span> you are 

reading is styled in my CSS file by the following. 

</p> 

Then in my CSS file I would add this style selector: 

.greenboldtext{  

font-size: small;  

color: #008080; 

font-weight: bold; 

} 

The final result would look like the following: 

To put it more simply, this sentence you are reading is styled in my CSS file by the 

following. 

Please note that a class selector begins with a (.) period. The reason I named it 

“greenboldtext” is for example purposes, you can name it whatever you want. Though I 
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do encourage you to use selector names that are descriptive. You can reuse the 

“greenboldtext” class as many times as you want. 

Example 1: 

<html> 

<head> 

<style type="text/css"> 

body 

{ 

background-color:#b0c4de; 

} 

</style> 

</head> 

<body> 

<h1>My CSS web page!</h1> 

<p>Hello world! This is a css eXAMPLE.</p> 

</body> 

</html> 

 

Example 2: 

<html> 

<head> 

<style type="text/css"> 

body {color:red;} 

h1 {color:#00ff00;} 

p.ex {color:rgb(0,0,255);} 

</style> 

</head> 

<body> 

<h1>This is heading 1</h1> 

<p>This is an ordinary paragraph. Notice that this text is red. The default text-color for a 

page is defined in the body selector.</p> 

<p class="ex">This is a paragraph with class="ex". This text is blue.</p> 
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</body> 

</html> 

 

Example 3: 

<html> 

<head> 

<style type="text/css"> 

p.ex1 

{ 

font:15px arial,sans-serif; 

} 

p.ex2 

{ 

font:italic bold 12px/30px Georgia,serif; 

} 

</style> 

</head> 

<body> 

<p class="ex1">This is a paragraph. This is a paragraph. This is a paragraph. This is a 

paragraph. This is a paragraph. This is a paragraph. This is a paragraph. This is a 

paragraph.</p> 

<p class="ex2">This is a paragraph. This is a paragraph. This is a paragraph. This is a 

paragraph. This is a paragraph. This is a paragraph. This is a paragraph. This is a 

paragraph.</p> 

</body> 

</html> 

Introduction to  Cascading Style Sheets 2 

Cascading Style Sheets, level 2, supports all of the functionality of CSS1. This means 

that if you create a CSS1 style sheet, it will work in a user agent that understands CSS2. 

Plus, the way that CSS1 is written, if you write a CSS2 style sheet, and load it in a CSS1-

only user agent, that agent will simply ignore the elements and properties that it doesn't 

recognize. 

Differences Between CSS1 and CSS2 

There are some really interesting differences between Cascading Style Sheets level 1 and 

level 2. CSS2 offers many new options for accessibility and use across various user 

agents. Positioning in CSS2 is more flexible and offers more options to the designer. 



Sardar azeem PICT 36 

AZEEM_AAG2000@YAHOO.COM  03135879331 

Automated content allows developers to force the user agent to display specific content 

elements as well as the layout, look, and feel. Also there is support for special cursors in 

CSS2 as well as dynamic outlining. 

Accessibility and CSS2 

Aural style sheets 

With CSS2, there are now style properties to define an aural style sheet for your 

documents. This means, that if a customer comes to your Web page with a screen reader 

that is CSS2 enabled, you can define how your page will sound. And this isn't just useful 

for blind customers, with aural CSS your documents can be listened to in automobiles, as 

auditory documentation for training, entertainment, and even for people who simply can't 

read. 

Paging 

CSS1 dealt almost solely with "continuous media" - that is, media like Web pages that 

would run continuously until the end. Paged media, such as paper, slide shows, or 

transparencies were not handled. But with CSS2, it is possible to define how pages 

should be displayed or printed. This means that you can specify the size of the page to be 

printed, add things like crop marks and register marks, or how the page should layout on 

double- and single-sided printings. 

Media Types 

CSS2 media types allow you to specify different style rules depending upon how your 

document is going to be displayed. There are many different types you can specify, 

including: aural, braille, handheld, screen, print, and tv (plus others). 

International Accessibility Features 

CSS2 now offers features such as more list styles for international documents, support for 

bidirectional text, and language-sensitive quotation marks. 

Improved Features over CSS1 

Font selection 

When choosing which font to use, CSS2 offers both the standard "name matching" 

system that CSS1 uses, plus three other methods for defining fonts. These are: intelligent 

font matching, where the user agent uses a font that is the closest match to the requested 

font. Font synthesis, where the user agent creates a font that matches the metrics of the 

requested font. And font download, where the user agent retrieves a font over the Web. 

Tables 

CSS2 recognizes that there might not be a table element (and related elements) in an 

XML document - but to display tabular data, it is important to have this as a style. So 

CSS2 allows you to define any element as a table element (and all the related table 

elements). 

Positioning 

While CSS1 had some aspects of positioning, CSS2 takes it to the next level. Relative 

and absolute positioning determine their location based on their placement within the 

document or based on the user agent. But along with absolute positioning is the concept 

of fixed positioning. This acts as a sort of "watermark" in continuous media. In paged 

media, an element with fixed position is repeated on every page. This allows you to 

create frame-like documents or place a signature on every page of a document. 

Cursors 

Now you can define how you want your cursor to respond to various actions. For 

example, you might want the default behavior over a link to be changed over some of the 

links in your document. With CSS2 you can define how the cursor should look over any 

element. 
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Introduction to XHTML. 
 
XHTML stands for eXtensable HyperText Markup Language and is a cross between HTML and 
XML. XHTML was created for two main reasons: 

 

1. To create a stricter standard for making web pages, reducing incompatibilities between 
browsers  

2. To create a standard that can be used on a variety of different devices without changes  

 
The great thing about XHTML, though, is that it is almost the same as HTML, although it is much 
more important that you create your code correctly. You cannot make badly formed code to be 
XHTML compatible. Unlike with HTML (where simple errors (like missing out a closing tag) are 
ignored by the browser), XHTML code must be exactly how it is specified to be. This is due to the 
fact that browsers in handheld devices etc. don't have the power to show badly formatted pages 
so XHTML makes sure that the code is correct so that it can be used on any type of browser. 
 
XHTML is a web standard which has been agreed by the W3C and, as it is backwards 
compatible, you can start using it in your webpages now. Also, even if you don't think its really 
necessary to update to XHTML yet, there are three very good reasons to do so: 

 

1. It will help you to create better formatted code on your site  
2. It will make your site more accessable (both in the future and now due to the fact that it 

will also mean you have correct HTML and most browsers will show your page better)  
3. XHTML is planned to replace HTML 4 in the future  

 
There is really no excuse not to start writing your web pages using XHTML as it is so easy to pick 
up and will bring many benefits to your site. 
 

The Main Changes 

 
There are several main changes in XHTML from HTML: 

 

• All tags must be in lower case  

• All documents must have a doctype  

• All documents must be properly formed  

• All tags must be closed  

• All attributes must be added properly  

• The name attribute has changed  

• Attributes cannot be shortened  

• All tags must be properly nested  

 
At a glance, this seems like a huge amount of changes but once you start checking though the list 
you will find that very little on your site actually needs to be changed. In this tutorial I will go 
though each of these changes explaining exactly what is different. 
 

The Doctype 

 
The first change which will appear on your page is the Doctype. When using HTML it is 
considered good practice to add a Doctype to the beginning of the page like this. 
 
Allthough this was optional in HTML, XHTML requires you to add a Doctype. There are three 
available for use. 
 
Strict - This is used mainly when the markup is very clean and there is no 'extra' markup to aid 
the presentation of the document. This is best used if you are using Cascading Style Sheets for 
presentation. 
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<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" 
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd"> 
 
Transitional - This should be used if you want to use presentational features of HTML in your 
page. 
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w 
3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">  
 
Frameset - This should be used if you want to have frames on your page. 
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Frameset//EN" 
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-frameset.dtd"> 
 
The doctype should be the very first line of your document and should be the only thing on that 
line. You don't need to worry about this confusing older browsers because the Doctype is actually 
a comment tag. It is used to find out the code which the page is written in, but only by 
browsers/validators which support it, so this will cause no problems. 
 

ocument Formation 

 
After the Doctype line, the actual XHTML content can be placed. As with HTML, XHTML has 
<html> <head> <title> and <body> tags but, unlike with HTML, they must all be included in a valid 
XHTML document. The correct setup of your file is as follows: 
 
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" 
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">  
<html> 
<head> 
<title>Page Title</title> 
OTHER HEAD DATA 
</head> 
<body> 
CONTENT 
</body> 
</html> 
 
It is important that your document follows this basic pattern. This example uses the transitional 
Doctype but you can use either of the others (although frames pages are not structured in the 
same way). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

PART 4 
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Dream Weaver 

Introduction To Dream Weaver: 

Macromedia Dreamweaver 8 is a professional HTML editor for designing, coding, and 

developing websites, web pages, and web applications. Whether you enjoy the control of 

hand-coding HTML, or prefer to work in a visual editing environment,  Dreamweaver 

provides you with helpful tools to enhance your web creation experience. 

The visual editing features in Dreamweaver let you quickly create web pages without 

writing a line of code. You can view all your site elements or assets and drag them from 

an easy-to-use panel directly into a document. You can streamline your development 

workflow by creating and editing images in Macromedia Fireworks or another graphics 

application, and then import them directly into Dreamweaver. Dreamweaver also 

provides tools that make it easy to add Flash assets to web pages. 

In addition to drag-and-drop features that help you build web pages, Dreamweaver 

provides a full-featured coding environment that includes code-editing tools (such as 

code coloring, tag completion, a coding toolbar, and code collapse) and language 

reference material on Cascading Style Sheets (CSS), JavaScript, ColdFusion Markup 

Language (CFML), and other languages. Macromedia Roundtrip HTML technology 

imports your hand-coded HTML documents without reformatting the code; you can then 

reformat code with your preferred formatting style. 

Dreamweaver also lets you build dynamic, database-driven web applications using server 

technologies such as CFML, ASP.NET, ASP, JSP, and PHP. If your preference is for 

working with XML data, Dreamweaver provides tools that let you easily create XSLT 

pages, attach XML files, and display XML data on your web pages. 

Dreamweaver is fully customizable. You can create your own objects and commands, 

modify keyboard shortcuts, and even write JavaScript code to extend Dreamweaver 

capabilities with new behaviors, Property inspectors, and site reports. 

 

Creating Web Project 

 

The first step in creating the site is to copy the sample files from the Dreamweaver 

application folder to an appropriate folder on your hard disk. 

1.    Create a new folder called local_sites on your hard disk. 

For example, create a folder called local_sites in either of the following two locations: 

■ In Windows: C:\Documents and Settings\your_user_name\My 

Documents\local_sites 

■ On the Macintosh: Macintosh HD/Users/your_user_name/ Documents/local_sites 

2.  Locate the cafe_townsend folder in the Dreamweaver application folder on your hard 

disk. 

If you installed Dreamweaver to its default location, the path to the folder is as follows: 

■ In Windows: C:\Program Files\Macromedia\Dreamweaver 

8\Tutorial_assets\cafe_townsend\. 
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■ On the Macintosh: Macintosh HD/Applications/Macromedia 

Dreamweaver 8/Tutorial_assets/cafe_townsend. 

3.  Copy the cafe_townsend folder into the local_sites folder. 

The cafe_townsend folder is the folder that you will use as the root folder (main folder) 

for your Dreamweaver site. 

Define a local folder 

You must define a Dreamweaver local folder for each new website you create. The local 

folder is the folder that you use to store working copies of site files on your hard disk. If 

you don’t define a local folder, certain features in Dreamweaver cannot work properly. 

Defining a local folder also allows you to manage your files and to transfer files to and 

from your web server by using a number of file-transfer methods. 

Now you’ll define the cafe_townsend folder that you copied into the local_sites folder as 

your local folder. 

1.    Start Dreamweaver and select Site > Manage Sites. 

The Manage Sites dialog box appears. 

2.  Click the New button and select Site. 

The Site Definition dialog box appears. 

3.  If the wizard (Basic tab) appears, click the Advanced tab and select Local 

Info from the Category list (it should be the default). 

4.  In the Site Name text box, enter Cafe Townsend as the name of the site. 

5.  In the Local Root Folder text box, specify the cafe_townsend folder that you copied to 

the local_sites folder in the previous section. 

You can click the folder icon to browse to and select the folder, or enter a path in the 

Local Root Folder text box. 

6.  In the Default Images Folder text box, specify the images folder that already exists in 

the cafe_townsend folder. 

You can click the folder icon to browse to and select the folder, or enter a path in the 

Default Images Folder text box. 

The Site Definition dialog box should now look as follows: 
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7.  Click OK. 

The Manage Sites dialog box appears, showing your new site. 

8.  Click Done to close the Manage Sites dialog box. 

The Files panel now shows the new local root folder for your current site. The file list in 

the Files panel acts as a file manager, allowing you to copy, paste, delete, move, and open 

files just as you would on a computer desktop. 

 

 
 

For more information about how the Files panel works, see “The Files panel. 

You’ve now defined a local root folder for your site. The local root folder is the place on 

your local computer where you keep the working copies of your web pages. Later, if you 

want to publish your pages and make them publicly available, you’ll need to define a 

remote folder—a place on a remote computer, running a web server, that will hold 

published copies of your local files. 
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Applying Html on Dream Waver. 

As you add text, images, and other content to a web page, Dreamweaver 8 generates 

HTML code. This tutorial explains how to use Code view to display a document’s 

underlying code, and how to add and edit code manually. 

Dreamweaver lets you view your page in either of two ways: Design view (where the 

document looks much like it would look in a browser), or Code view (where you can see 

the underlying HTML code). You can also use a split view that shows both Code and 

Design views simultaneously. 

1.    Make sure the index.html file is open in the Document window. 

2.  In the Document toolbar, click Show Code and Design Views (which is labeled Split). 

The window splits, showing both the Design view and the underlying 

HTML code. 

You can edit the code in Code view. Changes you make to the code don’t appear in 

Design view until you either click Refresh in the Document toolbar, or click anywhere in 

Design view. 

 

You can edit the code in Code view. Changes you make to the code don’t appear in 

Design view until you either click Refresh in the Document toolbar, or click anywhere in 

Design view. 

3.  (Optional) To show Design view only, click Design view. 

4.  (Optional) To show Code view only, click Code view. 

When you’re working on your own pages, you can use whichever view is most 

comfortable for you. Most of the tutorials in this guide assume that you’re using Design 

view. 

Add  a tag with the Tag Chooser Next, you’ll use the Tag Chooser to wrap a div tag 

around one of the images on the page. You can then assign margins, borders, or colors to 

the image as you desire. There are a variety of ways to wrap a div tag around 

an image; this section explains how to use the Tag Chooser, which helps you insert any 

tag and add appropriate attribute values. 

1.    Open the index.html file, if it’s not already open. 
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2.  In Design view, click the Cafe Townsend banner graphic 

(banner_graphic.jpg) to select it. 

 
 

 

 

3.  Switch to Code view by clicking Code view in the Document toolbar, or by selecting 

View > Code View. 

You’ll see that the code for the selected image is selected in Code view. Make sure the 

entire img  tag is selected, including the opening and closing angle brackets. 

 
 

 

4.  If it isn’t already enabled, select View > Code View Options > Word 

Wrap to enable word wrap. 

5.  Right-click (Windows) or Control-click (Macintosh) the selected text, and then select 

Insert Tag from the pop-up menu. 

The Tag Chooser appears. 

6.  In the Tag Chooser, expand the HTML Tags category, followed by the 

Formatting and Layout subcategory; then select General. 

A list of tag names appears in the right pane; select div from that list. 
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Click Insert. 

A tag editor for the div tag appears. 

8.  In the tag editor, select the Style Sheet/Accessibility category and enter 

banner in the ID text box. 

9.  Click OK to close the tag editor and insert the tag. 

Dreamweaver inserts the div tag in your page, wrapping it around the image tag. 

 

 

 

 

 

 

 

 

10.  Click Close to close the Tag Chooser. 

11.  Save your page. 

Edit  a tag 

Next, you’ll use the Tag inspector to quickly make changes to a tag’s attributes. The Tag 

inspector displays the attributes of the tag that’s selected in the Document window. 

1.    Open the index.html page in Code view, if it’s not already open. 

2.  Open the Tag inspector, if it’s not already open, by selecting Window > Tag Inspector. 

3.  Select the Attributes tab. 

4.  Click Show List View in the Tag inspector to view all of a selected tag’s attributes in 

alphabetical order 

In the Document window’s Code view, click anywhere between the opening and closing 

brackets of any tag. 

The Attributes tab of the Tag inspector shows information about the tag’s HTML 

attributes. 
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The Attributes tab of the Tag inspector shows information about the image tag’s 

attributes. 

7.  In the Tag inspector, click in the empty text box beside the alt attribute, and type Cafe 

Townsend; then press Enter (Windows) or Return (Macintosh). 

Dreamweaver displays the new value in the Tag inspector and changes the code in the 

Document window. 

8.  Save your page. 

CSS and its Implementation on Dream waver 

Many websites use table-based layouts to display information on their pages. Tables are 

useful for presenting tabular data (such as rows and columns of repeating elements) and 

are extremely easy to create on a page. But tables also tend to generate a great deal of 

code that is difficult to read and maintain. Additionally, because of the amount of tags 

required, and the potential for “nesting,” tables can cause problems for disabled people 

who are using screen readers to view web pages. 

A CSS-based layout—that is, a layout that uses block elements instead of table rows and 

columns—contains much less code than a table-based layout of the same nature. CSS-

based layouts generally use <div> tags instead of <table> tags to create CSS layout 

blocks used for layout. You can position these CSS layout blocks anywhere on the page, 

and assign properties to them such as borders, margins, background colors, and so on. 

Additionally, people using screen readers to view web pages have a much easier time 

browsing pages built with CSS because the code is simpler and shorter. 

Dreamweaver lets you create layers. A Dreamweaver  layer is an HTML page element 

that you can position anywhere on your page. More specifically, it is a <div> tag (or any 

other tag) with an absolute position. You use Dreamweaver to drag layers on your page 

and then position the layers where you want them. The layers act as content blocks that 

hold assets like images, Flash files, text, and so on. 

Create and save a new page 

After you set up a site and examine any comps, you are ready to begin building web 

pages. You’ll start by creating a new page, and saving it in the cafe_townsend local root 

folder of your website. The page eventually becomes the home page for Cafe Townsend, 

a fictional restaurant. 

If you haven’t created the cafe_townsend local root folder, you must do so before you 

proceed. For instructions,  see Chapter 3, “Tutorial: Setting Up Your Site and Project 

Files.” 

1.    In Dreamweaver, select File > New. 

2.  On the General tab of the New Document dialog box, select Basic Page from the 

Category list, select HTML from the Basic Page list, and click Create. 

3.  Select File > Save As. 

4.  In the Save As dialog box, browse to and open the cafe_townsend folder that you 

defined as the site’s local root folder. 

In Chapter 3, “Tutorial: Setting Up Your Site and Project Files”, you created this folder 

within a folder called local_sites. 

5.  Enter index_css.html in the File Name text box and click Save. 
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The filename now appears in the title bar at the top of the application window, in 

parentheses. 

6.  In the Document Title text box at the top of your new document, type 

Cafe Townsend. 

 
 

This is the title of your page (different from the filename). Your site visitors will see this 

title in the browser window title bar when they view the page in a web browser. 

7.  Select File > Save to save your page. 

Draw a new layer 

1.    With the index_css.html page open in the Document window, select 

Layout mode from the Insert bar. 

 
 

2.  Click Draw Layer. 

 

The mouse pointer changes to a cross when you move it over the page. 

3.  Drag a layer of any size onto the page and release the mouse button. 

4.  Click the selection handle at the upper-left corner of the layer to make sure that it is 

selected. 

5.  With the new layer selected, do the following in the Property inspector 

(Window > Properties): 

■  Click  in the Layer ID text box and rename the layerbanner_graphic. 

■ In the Width (W) text box, enter 700px. 

■ In the Height (H) text box, enter 90px. 

■ In the Left (L) text box, enter 20px. 

■ In the Top (T) text box, enter 20px. 
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■  Press Enter (Windows) or Return (Macintosh) to apply your last entry. 

 

Dreamweaver  sizes and positions the new banner_graphic  layer. The banner_graphic 

layer is 700 pixels wide by 90 pixels high. It is also positioned 20 pixels from the left 

margin of the page, and 20 pixels from the top margin of the page. 

6.  Open the Layers panel (Window > Layers). You’ll see that Dreamweaver has added 

the new layer (banner_graphic)  to the list of layers. 

7.  Click once outside the new layer to deselect it. 

8.  Save your page. 

Add more layers 

Now you’ll add more layers to the page. You’ll use the first layer (banner_graphic)  as a 

reference point for positioning the other layers. You’ll also use the CSS Layer 

Backgrounds feature to help you position and distinguish between layers. 

1.    In the Layout category of the Insert bar, click Draw Layer and drag another layer of 

any size on the page. 

 

 

 

 

 

 

 

 

 

2.  Click the new layer’s selection handle to select it. 

3.  With the new layer selected, do the following in the Property inspector: 

■  Click  in the Layer ID text box and rename the layer flash_fma. 

■ In the Width (W) text box, enter 700px. 

■ In the Height (H) text box, enter 166px. 

■ In the Left (L) text box, enter 20px. 

■ In the Top (T) text box, enter 111px. 

■  Press Enter (Windows) or Return (Macintosh) to apply your last entry. 

Dreamweaver  sizes and positions the new flash_fma layer. 
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The flash_fma layer is 700 pixels wide by 166 pixels high. It is also positioned 20 pixels 

from the left margin of the page, and 111 pixels from the top margin of the page. You 

positioned this layer 111 pixels from the top margin of the page so that it would not 

overlap with the banner_graphic layer. 

When layers overlap, you’ll notice that the border of one of layers 

(specifically, the underlying layer) is represented by a dotted a line. 

4.  Click once outside the new layer to deselect it. 

5.  Select View > Visual Aids > CSS Layout Backgrounds 

 

 

Dreamweaver adds background colors to your layers. These colors are randomly selected 

and do not appear on the published web page. They are merely visual aids that 

Dreamweaver provides to help you see where layers and other kinds of block elements 

appear on the page. 

You can optionally disable CSS Layout Backgrounds again by selecting 

View > Visual Aids and deselecting CSS Layout Backgrounds. 
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6.  Next, drag three more layers onto the page, underneath the banner_graphic layer and 

the flash_fma layer. 

Remember to click Draw Layers in the Insert bar each time before you drag a new layer. 

 

7.  After you have three more layers on the page, use the Property inspector to do the 

following: 

■  Select  the first layer, name it header, and size it to 700 pixels wide by 24 pixels 

high. 

■  Press  Enter (Windows) or Return (Macintosh) to apply your last entry. 

■  Select  the second layer, name it center_content, and size it to 700 pixels wide by 

350 pixels high. 

■  Press  Enter (Windows) or Return (Macintosh) to apply your last entry. 

■  Select  the third layer, name it footer, and size it to 700 pixels wide by 24 pixels 

high. Press Enter (Windows) or Return (Macintosh) to apply your last entry. 

When you’re finished, your page should look something like this: 
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8.  Next, select the header layer and drag the selection handle until the header layer is 

positioned directly beneath the flash_fma layer. 

You can check your position from time to time as you drag the layer by clicking outside 

the layer to deselect it. 

 

 
 

9.  Select and drag the center_content  layer and the footer layer, or use the arrow keys on 

your computer to position the layers, as the following example shows: 

10.  After your layers are in position, disable CSS Layout Backgrounds (if it isn’t 

already) by selecting View > Visual Aids and deselecting CSS Layout Backgrounds. 

Add  layers inside a layer 

The last layers you’ll draw will be inside the large center_content  layer. These layers act 

as the equivalent of the table cells you added to the page if you completed Chapter 4, 

“Tutorial: Creating a Table-based Page Layout.” 

1.    Click once to the right of your layers to make sure everything is deselected. 

2.  In the Layout category of the Insert bar, click Draw Layer and drag another layer 

inside the center_content  layer as the following example shows: 

 
 

3.  Click the new layer’s selection handle to make sure the layer selected. 

4.  With the new layer selected, do the following in the Property inspector: 
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■  Click  in the Layer ID text box and rename the layer navigation. 

■ In the Width (W) text box, enter 140px. 

■ In the Height (H) text box, enter 350px. 

■ In the Left (L) text box, enter 20px. 

■  Press Enter (Windows) or Return (Macintosh) to apply your last entry. 

5.  Use the Up Arrow key on your keyboard to move the navigation layer until it fits 

perfectly within the center_content  layer, as the following example shows: 

 

6.  Create another layer in the center_content layer by 

clicking Draw Layer and dragging another layer, as the 

following example shows: 

 
 

7.  Click the new layer’s selection handle to make sure the layer is selected. 

8.  With the new layer selected, do the following in the Property inspector: 

■  Click  in the Layer ID text box and rename the layer flash_video. 

■ In the Width (W) text box, enter 230px. 

■ In the Height (H) text box, enter 350px. 
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■  Press  Enter (Windows) or Return (Macintosh) to apply your last entry. 

9.  Drag the flash_video layer or use the arrow keys on your keyboard to position the 

layer as the following example shows: 

 
 

10.  Create one more layer in the center_content  layer by clicking Draw 

Layer and dragging another layer as the following example shows: 

 

11.  Click the new layer’s selection handle to make sure the layer is selected. 

12.  With the new layer selected, do the following in the Property inspector: 

■  Click  in the Layer ID text box and rename the layer text. 

■ In the Width (W) text box, enter 330px. 

■ In the Height (H) text box, enter 350px. 

■  Press  Enter (Windows) or Return (Macintosh) to apply your last entry. 

13.  Drag the text layer or use the arrow keys on your keyboard to position the layer as 

the following example shows: 
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14.  Save your page. 

Add  color to the page 
 

Now you’ll add color to the page by setting background colors for some of the layers, and 

for the background of the entire page. 

1.    Select the navigation layer by clicking its name in the Layers panel 

(Window > Layers). 

 

 
 

2.  In the Property inspector, click once inside the Background Color text box. 

The text box is located directly next to the Background Color (Bg) 

color box. 

3.  In the Background Color text box, enter the hexadecimal value 

#993300 and press Enter (Windows) or Return (Macintosh). 

 

 

The background color of the navigation layer turns to reddish-brown. 

4.  Select the flash video layer by clicking its name in the Layers panel. 
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5.  In the Property inspector, click once inside the Background Color text box, enter the 

hexadecimal value #F7EEDF, and press Enter (Windows) or Return (Macintosh). 

The color of the flash_video layer turns to light tan. 

6.  Repeat the previous steps to change the color of the text layer to light tan as well. 

7.  Once you’ve set the background colors for all three layers, click once to the right of all 

of your layers to make sure nothing is selected. 

Next you’ll change the background color for the entire page by modifying page 

properties. The Page Properties dialog box lets you set a number of page properties, 

including the size and color of page fonts, the colors of visited links, page margins, and 

much more. 

8.  Select Modify > Page Properties. 

9.  In the Appearance category of the Page Properties dialog box, click the Background 

Color color box and select black (#000000)  from the color picker. 

 

10.  Click OK. 

Your page background turns to black. 

11.  Save your page. 

Your CSS page layout is now complete. The layout contains a number of layers that can 

hold assets such as images, text, and Flash Video files. Your next step is to add the 

content. 

If you completed Chapter 5, “Tutorial: Adding Content to Pages,” you know that you can 

use Dreamweaver to easily insert assets in your page. If you didn’t complete that tutorial, 

you can use the illustrations as a reference while adding content to the CSS-based page 

layout you just completed. 

You can find the completed version of this tutorial in the cafe_townsend/ 

completed_files/dreamweaver folder. 

Creating Menus In Dream weaver 

Dreamweaver makes it easy to create drop-down menus for your Web site. But like all 

HTML forms they can be a bit tricky 

Dreamweaver Jump Menus 

http://webdesign.about.com/od/forms/
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Dreamweaver 8 also provides a wizard to create a jump menu for navigation in your Web 

site. Unlike basic drop-down menus, this menu will actually do something when you are 

finished. You won't have to write any JavaScript or CGIs to get your drop-down form to 

work. This tutorial also explains how to use the Dreamweaver 8 wizard to create a jump 

menu. 

First Create the Form 

How to Create a Drop-Down Menu in Dreamweaver 

 

 

 

 

 

Form Displays in Design View 

 

 

 

Choose List/Menu 
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Special Options Window 

 

Form Accessibility 
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Select the Menu 

 

Menu Properties 

 

 Add New List Items 

 

 Add More and Reorder 

 

Give All Items Values 
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Choose a Default  

  

See Your List in Design View 

 

 

 

See Your List in Code View 

 

 Save and View in Browser 

  

But It Doesn't DO Anything 
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Jump Menu Window 

 

Add Items to Your Jump Menu 
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Jump Menu Options 

 

Jump Menu Design View 

 

Jump Menu in Browser 



Sardar azeem PICT 61 

AZEEM_AAG2000@YAHOO.COM  03135879331 

 

 

 

Layout Of Dream weaver 

In Windows, Dreamweaver provides an all-in-one-window integrated layout. In the 

integrated workspace, all windows and panels are integrated into a single larger 

application window 

 

 

 

The Document window 

The Document window shows the current document. You can select any of the following 

views: 
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Design view is a design environment for visual page layout, visual editing, and rapid 

application development. In this view, Dreamweaver displays a fully editable, visual 

representation of the document, similar to what you would see viewing the page in a 

browser. 

The Document toolbar 

The Document toolbar contains buttons that let you toggle between different views of 

your document quickly: Code, Design, and a split view that shows both Code and Design 

view. 

 

The status bar 

The status bar at the bottom of the Document window provides additional information 

about the document you are creating. 

 

The Insert bar 

The Insert bar contains buttons for creating and inserting objects such as tables, layers, 

and images. When you roll the pointer over a button, a tooltip appears with the name of 

the button. 

The buttons are organized into several categories, which you can switch on the left side 

of the Insert bar. Additional categories appear when the current document contains server 

code, such as ASP or CFML documents. When you start Dreamweaver, the category you 

were last working in opens. 

 

The Coding toolbar 

The Coding toolbar contains buttons that let you perform many standard coding 

operations, such as collapsing and expanding code selections, highlighting invalid code, 

applying and removing comments, indenting code, and inserting recently used code 

snippets. The Coding toolbar is visible only in Code view and appears vertically on the 

left side of the Document window. 
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The Property inspector 

The Property inspector lets you examine and edit the most common properties for the 

currently selected page element, such as text or an inserted object. The contents of the 

Property inspector vary depending on the element selected. For example, if you select an 

image on your page, the Property inspector changes to show properties for the image 

(such as the file path to the image, the width and height of the image, the border around 

the image, if any, and so on). 

 

The Files panel 
 

You use the Files panel to view and manage the files in your Dreamweaver site. 

 
 

 

 

 

 

 

 

 

 

Slicing. 

Create a website header using Photoshop 
 

Open Photoshop and click on File/Open and select the header image from your website 

folder. 

Name the layer header in the layers panel. Right click on the layer and select Duplicate 

Layer. Name the second layer candle.  

 

Click on layer header and press shift+ctrl+u to desaturate the picture. You won't be able to 

see the desaturation as the layer is behind the candle layer. You can close the eye of the 
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candle layer in the layers panel if you would like to view the effect of the desaturation. 

 

Now work on the candle layer. Select Elliptical marquee tool. Drag it to the candle. Select 

feather radius as 15. 

 

 

 

Now click on Select>Inverse from the top menu and then delete. 

 

Now press ctrl+D to deselect the candle. Make a new layer called candleborder on top of the 

candle layer. Use the line tool to create a vertical line on the left and on the right of the lit 

candle.  

 

 

The above is the final effect you will create.  

If you would like to use this header in the next tutorial on creating a website layout, You have to 

merge the layers to create a single graphic. You need to do the following steps : 

1. Click on the link icon next to the eye icon in the layers panel for all the layers.  

 

2. Go to Layers>Merge Linked.  

Your header is ready to insert in the layout. Click here to learn how to create a website layout 

using this header in Photoshop. 

Design a website layout in Photoshop 

 

http://www.entheosweb.com/photoshop/layout.asp
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We have designed a layout with a black background with an area for the logo, an eye-catching 

graphical header, navigation links, content and images.  

Remember while designing your layout, you need to define spaces for the following :  

• Header - This could be a graphic banner 

• Logo 

• Buttons - Links for home, about us, contact us etc.  

• Pictures 

• Content area 

• Copyright Information 

Follow the following steps to design your website layout in Photoshop:  

1. Open a new file in Photoshop by clicking on File/New and enter a width of 750pixels 

and height of 450px.  

2. Color the background with Black by choosing black in the foreground color 

and selecting the paint bucket tool and click on the canvas. Your background 

will now be black.  

3. Add a new layer by clicking on the Add Layer icon in the Layers panel. If your Layers 

panel is not open then go to Window/Layers. Name the new layer copyright . Select 

Rectangle Marquee Tool and drag to make the bottom banner with a width of 

750pixels by 21 pixels. Color this banner with color #303030.  

4. Choose Horizontal Type Tool. A text layer is created automatically. Now enter 

the text for Copyright, e.g. "Copyright © 2005 www.YourWebBusiness.com. All Rights 

Reserved.  

5. Choose Horizontal Type Tool. A text layer appears automatically. Enter the button text 

on the top banner too: "home l sitemap l news l downloads".  

6. Add a new layer. Now make the gray horizontal line color #808080 with single 

Marquee tool.Go to Edit>Stroke. Choose Stroke width 1 pixel. Color #808080. 

Location Center. Click OK.  

 

7. Right click on the layer and select duplicate layer 3 times, because you have 4 lines. 

Put the lines in their corresponding place: in bottom, middle, top.  

8. Now you can enter the button text on the second top banner in a new layer e.g. About 

us l services l products l clientele l contact us. 

9. Now define the logo area with the rectangular marquee tool. Go to Edit>Stroke. 

Choose Stroke width 1 pixel. Color is #808080. Location Center. Fill inside with Black 

color with Paint tool. Name it Logo area.  

10. Choose the Horizontal Type Tool and write your company name or website 

name. 

11. Choose the Horizontal Type Tool and enter content in the middle.  

12. Insert your header (See our tutorial on creating an eye-catching header). This could 

also be any image you choose. The image needs to be a horizontal banner. Open 

http://www.entheosweb.com/photoshop/header.asp
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your image file. Go to move tool. Drag from your image file to this layout in the middle 

of the layout.  

13. Draw the boxes seen on the right with the Polygonal Lasso Tool. 

Go to Edit>Stroke. Choose Stroke width 1 pixel. 

Color is #808080. Location Center.  

Name your layer borderpics. Make two more Boxes. Adjust them equally in the right 

side of the layout. Insert the images by dragging them to your layout and naming the 

layers.  

14. Drag the layer borderpics on top of the 3 pic layers. The edges of the pictures have to 

be cut according to the design of the box.  

15. Now create the white bands with text at the bottom of each of the right graphics with 

the rectangle marquee tool. Fill the box with white color with Paint tool. Name it 

"whitebandpics". Choose the Horizontal Type Tool. A text layer is created 

automatically. Now enter the text for Gifts. Follow the same for the rest of the pictures. 

You can click here for the images - pic1, pic2, pic3. You can drag these images to 

your layout.  

 

Now when your design is ready, you can go to the next step to creating your website 

which is to make slices.  

Slice your layout and export images using Photoshop 

Follow these steps to slice your layout.  

1. Open the file you want to slice clicking on File>Open. You can open the above layout. 

Important : You have to organize your layout in such a way that you should be able to 

put them into rows and columns in a table in Dreamweaver.  

You can write down how you are going to slice your layout to get the idea. Anything that 

is text and backround colors can be done easily in Dreamweaver. Only images and 

graphis have to be sliced in Photoshop. 

2. Here we will slice only 3 images i.e. the logo, banner and the graphics on the right. Now 

you can start to slice your layout. Select the slice tool and draw a box to define the 

area you want to slice. We will first create a slice for the logo. Next, use the slice tool 

again to drag across the banner and create the next slice. Repeat for the graphics found 

on the right with the dotted line. Create one slice for all the 3 images. View the completed 

layout to check the slices. 

3. Next, we will name the slices. Go to the slice tool in the menu palette and select the Slice 

Select Tool. Now double click on the slice. A screen named Slice Options will 

come. Enter the type of the slice, as an image and name of the slice. For the logo slice, 

give the name logo. Repeat this step to name the banner slice and the graphics slice. 

You can name them banner and pic right.  

4. Go to File > Save for web. A screen named Save for web will come. Select the logo 

slice and choose gif from the drop down menu. next, select the banner and pic right 

http://www.entheosweb.com/images/photoshop/pic1.jpg
http://www.entheosweb.com/images/photoshop/pic2.jpg
http://www.entheosweb.com/images/photoshop/pic3.jpg
http://www.entheosweb.com/photoshop/slice.asp
http://www.entheosweb.com/photoshop/downloads/my%20layout.psd
http://www.entheosweb.com/photoshop/downloads/my%20layout.psd
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slices and select JPEG and maximum from the drop-down menus.  

Tip : Remember photographs should always be exported as JPEG and solid colors can 

be exported in .GIF formats Adaptive Colors 256. 

5. Now the slices are ready to be exported. Select the 3 sliced images in the save for web 

pop-up box by using the shift key. Click on Save.  

6. A screen named Saved Optimized As will appear. Save your slices in your website 

folder. Make sure your image file is in the same path as your work file. Choose the 

following options for the rest of the options:  

Save as type: Choose Images Only 

Slices: Choose selected slices.  

 

Now click on Save. Check that the 3 images have been saved in the images folder in your web 

site folder. Proceed to creating the website in Dreamweaver.  

 

 

Create your website in Dreamweaver 

1. Open Dreamweaver. 

2. Go to File>Site>New site. A big screen named Site definition will open where you have 

to give all the instructions for your site.  

 

Site Definition Screen. 

o In the first screen you need to give a name to your site. Click Next.  

o Select No, I do not want to use a server technology. Click Next.  

o In the third screen, Editing Files Part 3, select your website folder using the folder 

icon. Click Next. This is the folder that contains your site images and .psd file.  

o In the next screen, "How do you connect to the remote server?" choose None 

from the drop-down menu. Click Next.  

o You will be able to view your site summary. Click on Done.  

3. Now you are ready to work on your site. Create a file called my-layout.html in 

Dreamweaver by clicking on File/New.  

 

Important : You need to visualize and organize your layout in such a way that you 

should be able to put them into rows and columns in a table in Dreamweaver.  

4. Open my-layout.html. Click on Insert/Table to insert a table in your web page. Enter The 

following :  

Rows : 7  

Columns : 1  

Table Width : 750 pixels 

http://www.entheosweb.com/photoshop/website.asp
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Border Thickness : 0 

Cell Padding : 0 

Cell Spacing : 0 

 

 

5. Now follow these steps :  

• Select the table and give 750 px and background as black in the Properties panel.  

 

• Keep your cursor in the first row and set the height as 21 pixels and choose Right from 

the Horz drop-down menu in the properties instructor. Enter the text Home | Sitemap | 

News | Downloads. Select the text and choose font Verdana size 10 pixels and color 

white in the Properties panel. Dreamweaver will automatically create a style called style 

1. We will use this style for the rest of the links also.  

We have entered 5 spaces between the links and the vertical bar. Tip: You can enter 

spaces by clicking on shift+Ctrl+Space.  

 

• For the thin line effect in Dreamweaver, keep your cursor in the second row and set the 

height 1 pixel and insert a spacer by choosing it from your images folder (Insert/Image). 

If you don't have a spacer image, you can get one here. Save it in your images folder. 

Give a gray background color #808080. 

• Bring your cursor to the third row and enter a height of 78 pixels in the properties panel. 

Now we will insert another table (Insert/Table) with 1 row and 3 columns so that the logo 

is inserted in the left and the navigation links are inserted on the right. 

Column 1: Give a width of 12 pixels. This is so that the logo does not stick to the edge of 

the page.  

Column 2: Insert the logo image by clicking on Insert/Image and selecting logo.jpg from 

the images folder.  

Column 3: Enter About Us | Services | Products | Clientele | Contact Us. Select the text 

and choose style 1 from the style drop-down menu. You should get the same style as the 

top navigation links - Verdana size 11 pixels and color white.  

• Bring your cursor to row 4 and give a height of 103px. Select Insert/Image and choose 

banner.jpg from the images folder and click on ok. Your banner will be inserted here. 

• Bring your cursor to row 5 and insert a table with 1 Row and 2 Columns.  

Column 1: Insert a table with cell padding of 20 pixels. Your content will be inserted 

here. Give a font style for the content - Font: Verdana Size : 12 pixels Color : white. 

Column 2: Give a width of 167 px and insert the graphics on the right by clicking on 

Insert/Image and choosing pic_right.jpg from the images folder.  

http://www.entheosweb.com/images/spacer.gif


Sardar azeem PICT 69 

AZEEM_AAG2000@YAHOO.COM  03135879331 

• Row 6: Repeat steps of row 2 to get the thin gray line.  

• Last and final row : Give the background color as #303030 and height as 21 pixels. Enter 

your copyright text and choose style 1 from the style drop-down menu in the Properties 

instructor. 

To preview your website in the browser, press F12.  

 

Forms 

1. The first step is to insert a form by clicking on Insert > Form 

2. The next step is to insert 3 text boxes for name, email and phone. Choose Insert > 

Form Objects > Text Field to insert 3 text boxes. Name the first text box 'Name', 

the second 'Email' and the third 'Phone' in the Properties inspector. 

3. Insert a submit button by clicking on Insert > Form Objects > Button 

4. Open the behaviors window by choosing Window > Behaviors. Select the form 

tag and click on the '+' icon in the behaviors window. Choose Validate Form 

5. In the pop-up window that appears choose the text field you want to validate and 

select the required validation.  

o Select Required for Name 

o Select Email for Email Address 

o Select Number for Phone 

6. Click on OK. 

7. Check the validation clicking on File > Preview in Browser 

Insert tables 
1.    Click once on the page to place the insertion point in the upper-left 

corner of the page. 
 

 
 

2.  Select Insert > Table. 

3.  In the Insert Table dialog box, do the following: 

■ Enter 3 in the Rows text box. 

■ Enter 1 in the Columns text box. 

■ Enter 700 in the Table Width text box. 

■  Select  Pixels from the Table Width pop-up menu. 

■ Enter 0 in the Border Thickness text box. 

■ Enter 0 in the Cell Padding text box. 

■ Enter 0 in the Cell Spacing text box. 

 

 



Sardar azeem PICT 70 

AZEEM_AAG2000@YAHOO.COM  03135879331 

 
 

 
4.  Click OK. 

A table with three rows and one column appears in your document. 

The table is 700 pixels wide with no border, cell padding, or cell 

spacing. 

 
5.  Click once to the right of the table to deselect it. 

6.  Select Insert > Table to insert another table. 

7.  In the Insert Table dialog box, do the following for the second table: 

■ Enter 1 in the Rows text box. 

■ Enter 3 in the Columns text box. 

■ Enter 700 in the Table Width text box. 

■  Select  Pixels from the Table Width pop-up menu. 

■ Enter 0 in the Border Thickness text box. 

■ Enter 0 in the Cell Padding text box. 

■ Enter 0 in the Cell Spacing text box. 

8.  Click OK. 

A second table with one row and three columns appears below your 

first table. 

 
9.  Click to the right of the table to deselect it. 

10.  Insert a third table by selecting Insert > Table and entering the following 

values in the Insert Table dialog box: 

■ Enter 1 in the Rows text box. 

■ Enter 1 in the Columns text box. 

■ Enter 700 in the Table Width text box. 

■  Select  Pixels from the Table Width pop-up menu. 

■ Enter 0 in the Border Thickness text box. 

■ Enter 0 in the Cell Padding text box. 

■ Enter 0 in the Cell Spacing text box. 

11.  Click OK. 

A third table, with one row and one column, appears below your 

second table. 
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Click to the right of the table to deselect it. Your page should now look as 

follows: 

 


